AE-1 Shutter problem

Discussion in 'Canon Cameras' started by Grumps, Feb 28, 2016.

  1. Grumps

    Grumps TPF Noob!

    Joined:
    Feb 28, 2016
    Messages:
    2
    Likes Received:
    1
    Can others edit my Photos:
    Photos NOT OK to edit
    Hi
    I have an old AE-1 that appears to mostly work. The problem is that the shutter speed control does not change the shutter timing. When set to B, 2s, 1s etc it is easily noticeable that the setting dial is making no difference. In fact, if you open the back and release the shutter, the curtains don't even appear to open.
    Anyone know if this is a common problem and easy to fix oneself?
    Ta.


     
    • Like Like x 1
  2. table1349

    table1349 Been spending a lot of time on here!

    Joined:
    Sep 9, 2006
    Messages:
    0
    Likes Received:
    3
  3. davidharmier60

    davidharmier60 No longer a newbie, moving up!

    Joined:
    Sep 9, 2017
    Messages:
    607
    Likes Received:
    163
    My well used AE-1 is sometimes slow to take a shot. IE it's cocked but pushing the button doesn't always fire it.

    Any thoughts?

    Sent from my SAMSUNG-SM-G890A using Tapatalk
     
  4. TCampbell

    TCampbell Been spending a lot of time on here!

    Joined:
    Mar 31, 2012
    Messages:
    3,289
    Likes Received:
    1,415
    Location:
    Dearborn, MI
    Can others edit my Photos:
    Photos OK to edit
    It probably needs to be lubricated — which is a tricky thing to do.

    There’s a YouTube channel called “Fix Old Cameras” and I seem to recall they have a video on how to deal with it. The telltale sign is that you hear a shutter squeak. It requires some partial disassembly of the body and a “clock oiler” it’s a long needle that you can bend to sneak it through a tiny opening and into the right spot).

    I did that with my own AE-1 and it took care of the problem.
     
  5. davidharmier60

    davidharmier60 No longer a newbie, moving up!

    Joined:
    Sep 9, 2017
    Messages:
    607
    Likes Received:
    163


    The one my Dad owned has WAY less shutter activations. I just need to put the winder cover off mine onto that one.

    Sent from my SAMSUNG-SM-G890A using Tapatalk
     

Share This Page