Canon 7D Zeikos grip

Discussion in 'Photography Equipment & Products' started by xsouthpawed, Nov 10, 2010.

  1. xsouthpawed

    xsouthpawed New Member

    Joined:
    Nov 8, 2009
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    0
    Gallery:
    Ratings:
    +0 / 0
    So I recently bought a Zeikos 7D grip for.. my 7D. But this is Day 2, and the grip no longer communicates with my camera. Everytime I turn on the camera, it displays "cannot communicate with battery". But, I'm using 1 Canon (OEM, came with the camera) and 1 generic (Power2000). Both the batteries display the battery life / percentage perfectly fine if inserted individually into the camera (no grip). Which leads me to think that there's something wrong with my grip. Any ideas? Thanks!
     
  2. j-dogg

    j-dogg New Member

    Joined:
    Jun 8, 2010
    Messages:
    526
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Flori-duh
    Gallery:
    Ratings:
    +5 / 0
    My Photos Are OK to Edit
    Try pushing the cartridge into the grip, my Rebel sometimes does this if I'm shooting weird angles.

    Also check the contacts on the grip.
     

Share This Page

Search tags for this page
canon 7d cannot cummunicate with battery
,
canon 7d grip
,
vello battery grip for 7d review
,

vello battery grip review

,

vello vs canon battery grip

,
vello vs zeikos
,
vello vs. zeikos
,
zeikos 7d battery grip review
,

zeikos vs vello battery grip

,
zeikos vs vello battery grip for canon 7d