Canon AE-1 Problem

Discussion in 'Beyond the Basics' started by 'Daniel', Jan 14, 2006.

  1. 'Daniel'

    'Daniel' TPF Noob!

    Joined:
    Dec 30, 2004
    Messages:
    1,507
    Likes Received:
    14
    Location:
    Manchester, UK
    I got a Canon AE-1 for christmas from Jessops (biggest UK camera shops for anyone who doesn't know) and am having some problems with it. I'm not sure if these are due to my own ineptitude or if there is actually somethnig wrong.

    When looking through the view finder and semi-holding the shutter release button the meter kicks in with a little red light and the little bar points to the Aperture it should be set to. This doesn't happen. However I don't tihnk it's the meter as the shutter isn't firing either. The battery is pretty much brand new I've shot ten exposures ever on the camera and it seems in good condition. Has anyone experienced anything like this.

    I looked at the manual online and it didn't really help.
     
  2. Digital Matt

    Digital Matt alter ego: Analog Matt

    Joined:
    Jan 30, 2004
    Messages:
    5,346
    Likes Received:
    65
    Location:
    Santa Barbara, CA
    Can others edit my Photos:
    Photos NOT OK to edit
    How have you shot ten exposures if you say the shutter isn't firing? I'm confused.
     
  3. 'Daniel'

    'Daniel' TPF Noob!

    Joined:
    Dec 30, 2004
    Messages:
    1,507
    Likes Received:
    14
    Location:
    Manchester, UK
    Sorry I fogot to say this happneed before briefly then fixed itself so I have been able to use it in part. But now it has stopped working again. This is why i think it might be something I don't know about that I have done to cause it to happen.
     
  4. Lumix

    Lumix TPF Noob!

    Joined:
    Dec 17, 2005
    Messages:
    32
    Likes Received:
    0
    Location:
    Suffolk, England.
    Try cleaning the battery contacts. Sounds like power is intermittent. Canon AE-1's don't work without power.
     
  5. Lol999

    Lol999 TPF Noob!

    Joined:
    Nov 8, 2005
    Messages:
    316
    Likes Received:
    0
    Location:
    Chesterfield, Derbyshire, England
    Also take it back to |Jessops. I think they offer 3 month warranty on second hand gear. Even if not, it's unreasonable for it to bust after such a short time. If you have no luck, try your trading standards people. That usually brings a little compliance from recalcitrant traders:mrgreen:

    Lol
     
  6. 'Daniel'

    'Daniel' TPF Noob!

    Joined:
    Dec 30, 2004
    Messages:
    1,507
    Likes Received:
    14
    Location:
    Manchester, UK
    Thanks alot I'll try cleaning it. And LOL lol999 I might try that. Maybe jessops will fix it for free if cleannig it doesn't work.
     
  7. Lol999

    Lol999 TPF Noob!

    Joined:
    Nov 8, 2005
    Messages:
    316
    Likes Received:
    0
    Location:
    Chesterfield, Derbyshire, England
    Either that or your money back, but you need to act sooner rather than later when complaining about second hand goods.

    Lol
     
  8. 'Daniel'

    'Daniel' TPF Noob!

    Joined:
    Dec 30, 2004
    Messages:
    1,507
    Likes Received:
    14
    Location:
    Manchester, UK
    Yeah definately. I'll see if it works and if not take it back next weekeend. Quite annoying hough. Might get somethnig else instead maybe a rolleicord. Dunno though.
     
  9. airgunr

    airgunr TPF Noob!

    Joined:
    Mar 21, 2004
    Messages:
    846
    Likes Received:
    4
    Location:
    Delavan, Wisconsin, USA
    Can others edit my Photos:
    Photos OK to edit
    Another thing to check is if you have the apapture ring set/locked to "A" or you have a manual apatuer selected. If it's not on "A" you get the red light I believe.
     
  10. 'Daniel'

    'Daniel' TPF Noob!

    Joined:
    Dec 30, 2004
    Messages:
    1,507
    Likes Received:
    14
    Location:
    Manchester, UK
    Nope that#'s not the problem I've tried various shutter speeds and apertures none seem to work. The lens is on properly also.

    Thanks for the suggestion though.

    Anyone else had any experience of this with a Canon AE-1 or other type.
     
  11. Mitica100

    Mitica100 Moderator Staff Member Supporting Member

    Joined:
    Nov 11, 2003
    Messages:
    9,746
    Likes Received:
    42
    Location:
    Ahwatukee, AZ
    Can others edit my Photos:
    Photos NOT OK to edit
    I've had some issues with and A1 and it came back to life after doing a little 'cleaning'. You'll need some Naphta or lighter fluid (the old style of lighters, with wick), a set of jewelers' screwdrivers, a white towel (to work on, so the little screws don't travel far if they fall), a few pointed tools (a sewing needle might work).

    Take the bottom plate off, setting the few screws aside in a little container. Look now at the innards of your AE1 and you'll see a little U shaped electromagnet. Take a drop or two of Naphta and drop it on anything that moves, especially at joints where there is friction. Repeat a few times then blow some air to disperse the dirt. Now turn the camera right side up and place a few drops of Naphta on the shutter button, by its side. Repeat a few times and allow the liquid to travel down a bit. Give it a try now. If it still doesn't work, put back the bottom plate, take the camera in one of your hands and give it a good whack against the other hand. It might well do it and start working again.

    Good luck.
     
  12. Lumix

    Lumix TPF Noob!

    Joined:
    Dec 17, 2005
    Messages:
    32
    Likes Received:
    0
    Location:
    Suffolk, England.
    If it don't work thump it is not a good idea. After cleaning the battery contacts make sure the battery is a good fit in the camera. The contacts may have been bent and not making good contact with the battery. If all this fails I urge you to take it back. Dismantling may invalidate your rights to return for refund or exchange.
     

Share This Page

Search tags for this page
blinking ae pointer on my 20d
,
blinking light canon ae 1
,
canon ae 1 flashing red
,

canon ae-1 meter problem

,
canon ae-1 not shooting viewfinder pointing `m`
,
canon ae-1 red light flashing
,
canon ae-1 red m
,
red metering light not working on canon
,
shutter on aei doesnt work
,
what is the blinking number on the light meter on a canon ae-1