Ebay Flash Trigger

Discussion in 'Photography Equipment & Products' started by junray, Oct 9, 2007.

  1. junray

    junray TPF Noob!

    Joined:
    Jun 21, 2007
    Messages:
    19
    Likes Received:
    0
    Just purchased a 4 channel ebay flash trigger from someone in hong kong through ebay. Purchased this trigger to play around with while I save for a Pocket Wizard. Anyway, I don't know if it just me but I can't get this damn thing to work. Change the battery, made sure the battery contact point was good and the channel correct. How hard could it be to make this thing work? I'm thinking it's probably the receiver since the led doesn't light up when I turn it on. Is it suppose to light up when you turn on the receiver?

    Does anyone use this trigger that had problem?

    TIA,
    JR
     
  2. keith204

    keith204 No longer a newbie, moving up!

    Joined:
    May 20, 2007
    Messages:
    1,643
    Likes Received:
    2
    Location:
    Bolivar, MO
    Can others edit my Photos:
    Photos OK to edit
    I'll take a couple stabs at this...

    when I got mine, I had the same problem.. ticked as you are.

    My problem was the battery had a plastic coating around it...so thin I didn't even see it was there. Did you take that off? (sounds obvious, but isn't really).

    Then, make sure your frequencies are set right, and your units on. The test button on the transmitter should make the test light on the receiver blink.
     
  3. Big Mike

    Big Mike I am Big, I am Mike Staff Member Supporting Member

    Joined:
    Dec 16, 2003
    Messages:
    33,817
    Likes Received:
    1,811
    Location:
    Edmonton
    Can others edit my Photos:
    Photos NOT OK to edit
    :lol:

    Yup, check to make sure the film around the battery has been taken off....the exact same thing happened to me. :er:
     
  4. Mike_E

    Mike_E No longer a newbie, moving up!

    Joined:
    Jan 26, 2007
    Messages:
    5,327
    Likes Received:
    264
    Location:
    The Upper West Side of Mississippi (you have no i
    Can others edit my Photos:
    Photos OK to edit
    Me too! LOL Then I had to bend in one of the contacts just a little so that it made better contact. They've worked great since then though.

    (be sure to turn the receivers off when not in use. ;))
     
  5. junray

    junray TPF Noob!

    Joined:
    Jun 21, 2007
    Messages:
    19
    Likes Received:
    0
    Thanks guys for the reply and suggestions. As stated above I've changed both battery in the receiver and transmitter. I've tried several channel configuration and made sure the contact point were good.

    As stated by Keith "the test button on the transmitter should make the test light on the receiver blink". I have never seen this led light up once even when I press the test button. I've got a feeling that I might have a bad receiver.

    Good news is that the seller replied to my email. Hopefully I can get this replace.

    I'll recheck the trigger again tonight when I get home from work. Even though I have hundred of times already.:)



    JR
     

Share This Page