Elan IIe (shutdown) problem

Discussion in 'Beyond the Basics' started by 35mmonline, Sep 21, 2004.

  1. 35mmonline

    35mmonline TPF Noob!

    Joined:
    Sep 21, 2004
    Messages:
    2
    Likes Received:
    0
    Was wondering if anyone might have some insight into a problem I'm having with my Elan IIe. A while back it started acting up with the following symptoms.

    I can get a low random number of shots off before the entire camera appears to shut down with a flashing dead battery indicator. I'm using an EF 28-105 USM lens on it when this happens. Right at the moment I don't have another lens to try to see if that's causing the problem.

    The lens appears to focus nice and fast and doesn't appear to make any unusual noises or such.

    I've tried different batteries, different brands. Also have cleaned the battery contacts and made sure there was plenty of contact pressure to the battery itself. I'm at a lose. Forgot to mention that once this problem happens I can turn the camera off and back on again and all works for a little while. The battery indicator shows full charge after cycling the camera and doesn't appear to get low before the problem occurs, it happens spontaneously and at random.

    Has anyone ever experienced such a problem?
     
  2. hobbes28

    hobbes28 Incredible Supporting Member

    Joined:
    Jul 10, 2004
    Messages:
    4,807
    Likes Received:
    41
    Location:
    at work...
    Not with the IIe. I'd find your local canon repair facility and see what they say. The IIe was one of those cameras that never seemed to have many problems from what I've heard.
     
  3. 35mmonline

    35mmonline TPF Noob!

    Joined:
    Sep 21, 2004
    Messages:
    2
    Likes Received:
    0
    Hmm, I just have to hope the cost of repairs will be worth it. I really like the camera, wouldn't mind trading it up for a digital EOS however. Not worth much with it's current little glitch.

    It's also odd that it never screws up the exposure, even when it malfuntions. Perhaps I should just get the verticle grip for it with the AA batteries.
     
  4. Scott WRG Editor

    Scott WRG Editor King of Smoothness

    Joined:
    Jun 21, 2004
    Messages:
    1,479
    Likes Received:
    16
    Location:
    Haverhill, MA
    I had this happen once... sorta, I don't remember the shot indicator but I did have it show a low battery and shut down. When I shut it off and turned it back on it was fine from then on.
     
  5. John

    John TPF Noob!

    Joined:
    Aug 4, 2004
    Messages:
    25
    Likes Received:
    0
    Location:
    Lake Dallas,Texas
    My wife had the very same problem with her Elan 11, some months back. I tried all the usual quick fixes and was to the point of sending it off for repair. What finally brought it back to life was simply changing from one lens to another. I did that and presto, it came on again. Good luck...John

    http://www.picturetrail.com/pa-paw
     
  6. BernieSC

    BernieSC TPF Noob!

    Joined:
    Jul 3, 2004
    Messages:
    270
    Likes Received:
    0
    Location:
    South Carolina
    sounds like the wonderful mystery of electronics you might as well send it to canon or an autorized canon repair center and let them check it out.
     
  7. locomocoloco

    locomocoloco TPF Noob!

    Joined:
    Sep 24, 2004
    Messages:
    2
    Likes Received:
    0
    It's either your battery contacts and battery door are not upgraded to taller one or your EF 28-105's diaphram not opening , sticking.

    When it happens again, check your lens diaghram before turn the power switch off. If it's closed then send lens to repair.

    good luck.
     

Share This Page

Search tags for this page
canon elan battery problems
,
canon elan ii e battery
,
canon elan ii low battery?
,
canon eos elan ii battery error
,
canon lan lle vs elan7
,

elan 7 shutting off

,
eos elan iie battery problem
,
how to put aa batteries in canon eos elan ii
,
how to turn on a canon eos elan
,
lan lle vs elan7