Film advancer stuck! Help!

Discussion in 'Collector's Corner' started by Dialectic10, Jun 29, 2011.

  1. Dialectic10
    Offline

    Dialectic10 New Member

    Joined:
    Jun 12, 2011
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Los Angeles, CA, USA
    Gallery:
    Ratings:
    +0 / 0
    My Minolta X-700's film advance lever is stuck. It won't turn. I was playing around and testing with the aperture and shutter speed yesterday, and after I unloaded my film this morning, the advance lever won't turn anymore.
    I put new batteries, but it still doesn't work.
    How do I fix it? Thanks
    Last edited: Jun 29, 2011
  2. compur
    Offline

    compur Well-Known Member

    Joined:
    Mar 6, 2008
    Messages:
    2,383
    Likes Received:
    281
    Trophy Points:
    83
    Location:
    L.A.
    Gallery:
    Ratings:
    +284 / 0
    This is a common problem with the X700, usually caused by failure of one or two capacitors
    in its circuitry. The fix is to replace them. (Often only one needs replacement.)

    If you are up to performing surgery on your camera (not advised without experience) you
    can find instructions here.

    Otherwise, best to let a professional repair person do it.
  3. Dialectic10
    Offline

    Dialectic10 New Member

    Joined:
    Jun 12, 2011
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Los Angeles, CA, USA
    Gallery:
    Ratings:
    +0 / 0
    Thanks. I did my own research and tried everything I can do without consulting a professional repair person.
    I managed to fix it.
    All I had to do was take a pencil eraser and rub it gently around the battery chamber. It worked. I don't really know how, but... it worked.
  4. compur
    Offline

    compur Well-Known Member

    Joined:
    Mar 6, 2008
    Messages:
    2,383
    Likes Received:
    281
    Trophy Points:
    83
    Location:
    L.A.
    Gallery:
    Ratings:
    +284 / 0
    Good for you!

Share This Page