Minolta X-300s

Discussion in 'Film Discussion and Q & A' started by Dimitar, Oct 6, 2008.

  1. Dimitar

    Dimitar TPF Noob!

    Joined:
    Oct 1, 2008
    Messages:
    4
    Likes Received:
    0
    Location:
    bremen, germany
    Can others edit my Photos:
    Photos OK to edit
    I have a little problem with this camera, maybe someone who has experience with it could help me. I've just bought it so I have no idea whether I'm doing something wrong or the camera is dead.

    I've put brand new batteries in it, but no film. So, I turn it on, press the shutter slightly and the leds in the viewfinder seem to work. Then I press the shutter all the way down, and the camera simply dies, those leds turn off and there's no mirror or anything else moving. Also the film advancement lever seems to be stuck, but I suppose that's related with the shutter not working.

    Any thoughts on this? I bought it quite cheap with nice collection of lens/flashes/filters, so don't know whether to return it or find another Minolta body or try to repair this one.
     
  2. Early

    Early TPF Noob!

    Joined:
    Feb 8, 2008
    Messages:
    1,240
    Likes Received:
    0
    Location:
    Western NJ
    Can others edit my Photos:
    Photos NOT OK to edit
    Sounds like it's history. Get another body that matches the lenses. Just stay away from the real cheapies like the one you bought.
     

Share This Page

Search tags for this page
minolta 300s
,
minolta x 300s
,
minolta x-300
,
minolta x-300 film advance lever stuck
,

minolta x-300s

,
minolta x-300s camera
,
minolta x300 shutter problem
,
minolta x300 shutter stuck
,
minolta x300 vs x300s
,

minolta x300s