Old Canon FTb help

Discussion in 'Film Discussion and Q & A' started by StreetShark, Mar 25, 2007.

  1. StreetShark

    StreetShark TPF Noob!

    Joined:
    Mar 11, 2007
    Messages:
    219
    Likes Received:
    0
    Well I've shot about 5 or 6 rolls of film with this camera and every single roll has come our blank. Any ideas as to what the problem is?
     
  2. Mitica100

    Mitica100 Moderator Staff Member Supporting Member

    Joined:
    Nov 11, 2003
    Messages:
    9,746
    Likes Received:
    42
    Location:
    Ahwatukee, AZ
    Can others edit my Photos:
    Photos NOT OK to edit
    If they're totally blank you might have a problem with the shutter curtains (not opening) or with the mirror not flipping up, although that should leave some light marks on the negative.

    I suggest taking the lens off from the camera and firing the shutter while looking at the camera from the front. That way you'll know whether it's the mirror or the shutter.
     
  3. StreetShark

    StreetShark TPF Noob!

    Joined:
    Mar 11, 2007
    Messages:
    219
    Likes Received:
    0
    Ok I did but every thing seems to be fine. The mirror goes up and the curtian opens. Any other ideas of whats wrong?
     
  4. Mitica100

    Mitica100 Moderator Staff Member Supporting Member

    Joined:
    Nov 11, 2003
    Messages:
    9,746
    Likes Received:
    42
    Location:
    Ahwatukee, AZ
    Can others edit my Photos:
    Photos NOT OK to edit
    Hmm... Have you loaded the films correctly into the camera? The older cameras need to be loaded differently than the newer ones, the film leader goes into a slot of the take-up spool. The film needs to be correctly engaged, otherwise it will never come out of its cartridge.

    Also, were the films good? Were they exposed to light or heat by mistake? Those could be the only other things I can think of.
     
  5. montresor

    montresor TPF Noob!

    Joined:
    Aug 22, 2005
    Messages:
    289
    Likes Received:
    0
    Location:
    Cleveland Hts., Ohio
    I have an FTb and it's got a funny kind of clamp mechanism for taking up the film, there's no slot in a spool. It's like a manual version of the automatic spooling in later cameras. Are you extending the film end all the way to the orange mark? It may not be taking up the film, for whatever reason. Mine works okay in that regard, but I could see where that device might be prone to age-related malfunction (like many of us old-timers!).
     

Share This Page

Search tags for this page

blank film canon ftb

,

blank negative canon ftb

,

blank+film+canon ftb

,

canon ftb film roll

,

canon ftb film rolls

,

exposing canon ftb

,

for sale canon ftb

,

fuji s4240

,

how do you roll the film in a canon ftb

,

what kind of pictures do canon ftb take?