Problems at working with Elinchrom Sckyports.

Discussion in 'Beyond the Basics' started by KhronoS, Aug 3, 2009.

  1. KhronoS

    KhronoS TPF Noob!

    Joined:
    Oct 8, 2007
    Messages:
    345
    Likes Received:
    0
    Location:
    Romania, Galati
    Can others edit my Photos:
    Photos OK to edit
    After a bit of investigation, i bought myself a pair of Skyports to get my 430EX flash of the camera. So basically i have a transmitter and a receiver, and an adapter so that i can connect a PC cable to my flash.
    So I connected the receiver to the adapter of the flash, put the transmitter on the hotshoe of the camera, turned everything on and seams that doesn't work.
    So know i am looking some help to make it work, or find what i am doing wrong. Maybe there must be something configured.

    The fact is that when i press the test button on the transmitter, nothing happens. Ohh and i have to add that i put a fresh battery on the transmitter, and the receiver was fully charger.
    So is there something i am missing? Is something wrong with the Skyports?
    Please let me know, especially the guys that used the skyports.

    P.S. My equipment is the Canon 430EX, with a Canon 40D. And the adapter i am talking about is the SM-601.
    Also if you have any more questions let me know.

    Thank you.
    Constantin Chirila
     
    Last edited: Aug 3, 2009
  2. GeneralBenson

    GeneralBenson TPF Noob!

    Joined:
    Mar 28, 2008
    Messages:
    1,106
    Likes Received:
    18
    Location:
    Boulder, CO
    Can others edit my Photos:
    Photos NOT OK to edit
    Allow me to help. Atleast I think I can. I bought a pair, and had the same issue. I tried putting a different battery in the transmitter, and no luck. Turns out they shipped the transmitter with the battery upside down, so it doesn't die. So when I put the new one in I put it in the same way as I took the old one out. Once I figured that out, and flipped the battery over, no problems since. Still on the original battery and have a spare to go with it. Try that, maybe it will help.
     
  3. KhronoS

    KhronoS TPF Noob!

    Joined:
    Oct 8, 2007
    Messages:
    345
    Likes Received:
    0
    Location:
    Romania, Galati
    Can others edit my Photos:
    Photos OK to edit
    Hey, thanks for your answer.
    Well i tried putting the battery both ways and still no effect.
    I have a quick question. If i take the transmitter and the receiver and both are connected to anything, or lets say that the transmitter is connected to the camera, if i press the test button, should the LED from the receiver blink?
    This way i can figure where is the problem between the camera and the trannmitter, transmitter and receiver or receiver and flash.

    Anyway waiting for your answer.
    Thank you.
    Constantin Chirila
     
  4. GeneralBenson

    GeneralBenson TPF Noob!

    Joined:
    Mar 28, 2008
    Messages:
    1,106
    Likes Received:
    18
    Location:
    Boulder, CO
    Can others edit my Photos:
    Photos NOT OK to edit
    Hmmm... I'll have to check on that when I'm home. Stupid question, but have you checked that everything is on the same channel and frequency? There's the chennel slider on the side that has 1-4, but there is also the frequency thing that is smaller and inset on the face of it.
     
  5. KhronoS

    KhronoS TPF Noob!

    Joined:
    Oct 8, 2007
    Messages:
    345
    Likes Received:
    0
    Location:
    Romania, Galati
    Can others edit my Photos:
    Photos OK to edit
    Yeah, i did chek to see if everything is on the same channel and frequency.
    Please let me know after you checked.

    Thank you.
     
  6. GeneralBenson

    GeneralBenson TPF Noob!

    Joined:
    Mar 28, 2008
    Messages:
    1,106
    Likes Received:
    18
    Location:
    Boulder, CO
    Can others edit my Photos:
    Photos NOT OK to edit
    Well, I checked, and when they're working properly, the light on the receiver does not blink when it receives a signal, even though the flash goes off. It only does the usual blink every 5 seconds or so to show that it's on.
     
  7. KhronoS

    KhronoS TPF Noob!

    Joined:
    Oct 8, 2007
    Messages:
    345
    Likes Received:
    0
    Location:
    Romania, Galati
    Can others edit my Photos:
    Photos OK to edit
    Thank you very much. I am thinking to go to the service and try to see how its done or what's wrong.
    Thanks again.
     

Share This Page

Search tags for this page
el skyport speed not firing
,
el-skyport not firing
,
el-skyport transmitter speed troubleshoot
,

elinchrom el-skyport receiver troubleshooting

,

elinchrom skyport doesn't work

,

elinchrom skyport not working

,

elinchrom skyport receiver not working

,
elinchrom skyport transmitter is not working
,
elinchrom transmitter not working
,
elinchrom wireless transmitter not working