Problems with SX-70 Land Polaroid Camera Model 2

Discussion in 'Film Discussion and Q & A' started by frazzzer, May 12, 2010.

  1. frazzzer

    frazzzer TPF Noob!

    Joined:
    May 12, 2010
    Messages:
    2
    Likes Received:
    0
    Can others edit my Photos:
    Photos OK to edit
    So I recently bought a sx-70 off ebay! I was so excited, get it through the post, put my first pack of film in and bam! Put the film in and the dark slide pops out, go to take a photo, the viewer goes black and nothing is spat out... The viewer remains blank for a while and sometimes, 'sometimes' it spits out an image. Rarely... Now I've tried three packs of film, the first photo somtimes comes out and develops but thats about it... One of my film packs was a 600 film (with filter), which I used in my 600 camera perfectly.. I just put a new pack in the camera and the first photo came out about 10 seconds after the viewer blacking out.. but thats about it

    Im really cheesed off, I'd love some help. thank you.
     
  2. compur

    compur No longer a newbie, moving up!

    Joined:
    Mar 6, 2008
    Messages:
    2,496
    Likes Received:
    317
    Location:
    L.A.
    If the film packs are OK, that is, they are putting out 6 volts (measured
    across the 2 round shiny spots on the bottom of the film pack), your SX70
    needs repair. If it was advertised as being in working condition, return it.
     
  3. frazzzer

    frazzzer TPF Noob!

    Joined:
    May 12, 2010
    Messages:
    2
    Likes Received:
    0
    Can others edit my Photos:
    Photos OK to edit
    Ah ********, it needs repair.. really?! >< I bought it of some highly rated collector from Ebay in america, and yes was advertised as working condition. I hope this isn't the real issue, I'm so annoyed.
     
  4. compur

    compur No longer a newbie, moving up!

    Joined:
    Mar 6, 2008
    Messages:
    2,496
    Likes Received:
    317
    Location:
    L.A.
    There isn't much complexity to using an SX70. You insert the film, point it
    and press the button. If it doesn't work the fault is either the film
    cartridge or the camera.

    I'm assuming you've unfolded the camera properly, inserted the film correctly
    and you're shooting in an area with sufficient light such as outdoors in
    daylight or in a brightly lit room.
     
  5. vonnagy

    vonnagy have kiwi, will travel...

    Joined:
    Sep 8, 2003
    Messages:
    3,759
    Likes Received:
    24
    Location:
    -36.855339, 174.762384
    Can others edit my Photos:
    Photos NOT OK to edit
    hi just to confirm are you using sx-70 film or 600 film, as sx-70 film goes to sx-70 cameras and 600 film goes to 600 film type cameras. Read more here.

    Polaroid SX-70 - Wikipedia, the free encyclopedia
     
  6. compur

    compur No longer a newbie, moving up!

    Joined:
    Mar 6, 2008
    Messages:
    2,496
    Likes Received:
    317
    Location:
    L.A.
    600 film can be used with SX-70 cameras.
     
  7. rom4n301

    rom4n301 TPF Noob!

    Joined:
    Dec 28, 2007
    Messages:
    614
    Likes Received:
    3
    Can others edit my Photos:
    Photos NOT OK to edit
    wait.. you do realize that some other company started make film that fits the sx-70 and all other polo cams. no need for modifications
     

Share This Page

Search tags for this page
polaroid land camera dark pictures problems
,
polaroid sx 70 issues
,
polaroid sx 70 model 2
,
polaroid sx-70 camera repair
,
polaroid sx-70 land camera model 2
,
polaroid sx-70 problems
,

polaroid sx-70 troubleshooting

,
polaroid sx70 problems
,
sx 70 model 2
,
why doesn't 600 film work on my sx-70?