Sigma 55-200 MM 1:4-5.6 DC, for my T1i....

Discussion in 'Photography Beginners' Forum' started by luncher, Feb 12, 2010.

  1. luncher

    luncher TPF Noob!

    Joined:
    Feb 12, 2010
    Messages:
    2
    Likes Received:
    0
    Sorry this may seem like a really newb Q but.....

    I recently decided to try out my first tele zoom lens, i bought a cheap Sigma 55-200 MM 1:4-5.6 DC, for my T1i....

    My question is , on the lens for the mount it shows the white dot.

    but when i try to connect the only way it will let me is to line up the white dot on the lens with the red dot on the t1i connection.

    This works and will connect as normal (locking click) as if I was using the white on white with the kit lens.

    Is this normal or am I incorrectly connecting the lens to the mount?

    The pictures seem to take fine and no problems that i see...but I always thought it was red on red white on white.?

    Thanks in advance
     
  2. TJ K

    TJ K No longer a newbie, moving up!

    Joined:
    Sep 9, 2008
    Messages:
    2,093
    Likes Received:
    1
    Location:
    Sunny South Florida
    Can others edit my Photos:
    Photos NOT OK to edit
    It's fine. If it connects and everything functions and the camera takes the shot you're all good.
    TJ
     
  3. DerekSalem

    DerekSalem TPF Noob!

    Joined:
    Aug 8, 2009
    Messages:
    660
    Likes Received:
    10
    Location:
    Cleveland, OH
    Can others edit my Photos:
    Photos OK to edit
    Sigma uses a red dot instead of white. Nothing to be alarmed about.
     
  4. luncher

    luncher TPF Noob!

    Joined:
    Feb 12, 2010
    Messages:
    2
    Likes Received:
    0
    Thank you
     
  5. AliasPros

    AliasPros TPF Noob!

    Joined:
    Jan 13, 2010
    Messages:
    354
    Likes Received:
    0
    Location:
    Central Coast CA
    Can others edit my Photos:
    Photos OK to edit
    Yes, as DerekS said, sigma does not use a red dot... Why? I don't know. On your Rebel, the red dot mean it's an EF mount and white dot means it's an EFS mount. EFS is only for cropped sensor cams and the EFS wont even mount on a 5D etc. Your Sig is an EF mount by what I here your describing so even though the colors don't match the mounts do. Does that make sens? LOL :raisedbrow:
     

Share This Page

Search tags for this page
buy sigma zoom af-bii 1:4~5.6 f=55~200 mm
,
sigma 55-200 1:4-5:6
,

sigma 55-200 1:4-5.6 dc

,

sigma 55-200 mm

,
sigma 55-200, 1:4-5.6 dc
,

sigma 55-200/4-5.6 dc

,

sigma 55-200mm 1:4-5.6 dc

,
sigma 55-200mm1:4-5.6 dc zoom lens review
,
sigma fr canon 55-200mm 1:4-5.6 dc
,
sigma zoom bii 1:4-5.6 55-200mm