Speedlight 420ex HELP!

Discussion in 'Digital Discussion & Q&A' started by deleet, Jun 23, 2008.

  1. deleet

    deleet TPF Noob!

    Joined:
    Jun 23, 2008
    Messages:
    3
    Likes Received:
    0
    Hey there,

    I recently purchased a speedlight 420ex for my Canon 40D last week. I've been having extreme trouble trying to understand how this is suppose to work with me camera. I remember the first time I hooked it up and turned it on, the flash was working fine and I was able to pull out good shots. But at one point, I had to be dependent on luck for the flash to go off.

    I don't think there is anything wrong with the flash it self because it turns on fine and the little red lights come up in the back. Zoom meter also works fine. I just don't understand - the camera just doesn't give a flash symbol when I have it hooked up. I've tried all different modes and even tried my friend's 430ex, and I get the same problems.

    I purchased my 40D last month and it was brand new, so I highly doubt there's anything wrong with that. Are there some functions I need to set in the camera? I went into the menu and enabled flash, but still nothing..

    What do I need to do? This is really aggravating me!

    Any help would be appreciated.
    Thanks!
     
  2. Big Mike

    Big Mike I am Big, I am Mike Staff Member Supporting Member

    Joined:
    Dec 16, 2003
    Messages:
    33,817
    Likes Received:
    1,811
    Location:
    Edmonton
    Can others edit my Photos:
    Photos NOT OK to edit
    Welcome to the forum.

    My first thought is that you might not be getting the flash all the way into the hot shoe. The flash has to be seated properly in the hot shoe for all 5 contacts to be connected. Some cameras may have a tight shoe so you really need to push the flash in all the way.

    If that doesn't work, then I'd suggest going into a camera store and trying the flash on a different camera and trying a different flash on your camera...that should help to narrow down the problem.
     
  3. deleet

    deleet TPF Noob!

    Joined:
    Jun 23, 2008
    Messages:
    3
    Likes Received:
    0
    Big Mike,

    Thanks for the quick reply! I did exactly what you said by making sure that the flash was seated properly into place - but still nothing..

    Unfortunately, I don't have another camera available to test the flash on. But as mentioned in my post, I also tried a brand new 430ex on the camera as well and that didn't work either.
     
  4. deleet

    deleet TPF Noob!

    Joined:
    Jun 23, 2008
    Messages:
    3
    Likes Received:
    0
    Never mind, the problem lied in the batteries..
    A photographer told me to always use Duracell, and I did - the flash works like a charm!
     

Share This Page

Search tags for this page

40d 420ex

,

420ex 40d

,
canon 420ex 40d
,
canon 420ex used on 40d
,
my canon 420exspeedlight flash doesnt work with my strobes
,
my speedlight 420 flash is not working
,

speedlight 420ex

,
speedlight 420ex slave not working
,
speedlite 420ex work with 40d
,
using a 420exwith a 40d