Sticky shutter?

Discussion in 'Beyond the Basics' started by patrean, May 7, 2006.

  1. patrean

    patrean TPF Noob!

    Joined:
    Feb 9, 2006
    Messages:
    4
    Likes Received:
    0
    I recently purchased a 24mm Carl Zeiss Jena II for my OM1 and sometimes when I fire the shutter it sticks and only releases when I give it a slight tap. Im wondering if this is a problem with the lens or my OM1. All my other lens work perfecly. Oddly enough when I mount the lens on my other OM1 body it seems to work fine. If the problem is with the lens is it something I could resolve myself or will I have to get a pro to look at it.

    Thanks for looking.
     
  2. Mitica100

    Mitica100 Moderator Staff Member Supporting Member

    Joined:
    Nov 11, 2003
    Messages:
    9,746
    Likes Received:
    42
    Location:
    Ahwatukee, AZ
    Can others edit my Photos:
    Photos NOT OK to edit
    Hi Patrean,

    It seems like the first of the OM-1 bodies might have a problem. Best bet would be to take it to a camera shop and have them take a look. Bring both bodies so you can show what happens with each one.

    BTW, the 'sticking' that occurs, is that of the diaphragm blades or is it the camera's shutter?
     
  3. Paul Ron

    Paul Ron TPF Noob!

    Joined:
    Oct 11, 2003
    Messages:
    498
    Likes Received:
    7
    Location:
    NYC
    Can others edit my Photos:
    Photos NOT OK to edit
    The problem is in the lens, it is gunked up with old lube. Have it cleaned and stop using it on your OM1 or you will develope problems in the body from all the strain on the delicate shutter system.
     

Share This Page

Search tags for this page
om-1 sticky shutter
,
om1 lube
,
photo forum
,

sticky shutter

,
sticky zeiss shutter
,
what is sticky shutter
,
what is sticky shutter?