How to use manual lens on Nikon D7100 DSLR ?


TPF Noob!
Jun 1, 2013
Reaction score
United States
Can others edit my Photos
Photos NOT OK to edit
I recently bought my first "old"/used fixed style lens off ebay. Just got in the mail and I was SO exited to try it out. It's a 85mm Nikkor AF f1:1.8 D manual lens. I have a Nikon D7100 . I tried searching on the internet to see if this lens was even compatible and it seems it is. But I have no idea what I'm doing wrong.

First I tried it on auto focus, then I changed the camera to manual focus and still nothing. It lets me focus manually from the lens, but the camera is acting like it doesn't recognize the lens and wont let me press the shutter button. Also, the letters f E E just flash on my screen in the upper right corner.
This is the lens I purchased: Nikon AF Nikkor 85mm F 1 8D Excellent Condition with Original Accessories 0018208019311 | eBay

In the auction He wrote " Please Note:
This lens will only auto-focus with camera body which has auto-focus motor (D200, D300, D90, D7000.... and up) and will only do manual focus with D40, D40x, D5000 series, D3000 series... "
So I figured since he mentioned above the d7000 and I have a D7100 it would auto focus. But if it didn't I was still ok, doing it in manual. I am wondering if there is some special setting in my camera I need to change so the camera will work with this lens?

Let me know if I just bought a lens that isn't even compatible. I am going to be taking pictures of a friend's almost 1 year old, for his1 year old pictures,and was exited to try this one out on him ,but wanted to practice with it at home first. The other two lens I have are new up to date auto focus lenses.
Turn the aperture ring to the largest number (16 in this lens' case). That will allows the camera to 'see' the lens. This is the step needed for all lenses with an aperture ring on Nikon DSLRs. When you do that, there will be a small mechanical 'switch' (next to the 1.8) you need to move to lock the ring into place.... otherwise you may accidentally move it and you will have your FEE error again.

Once you do that, the body motor will turn the lens into focus (assuming you turn the AF on the body back on).
YEEEESS!!!!!! THANK you, thank you !! When it arrived in the mail, that focusing ring was on the 16,and it was on lock. I thought the seller did that for the shipping of the lens,to keep it from moving or shifting.. I unlocked it and should have left it alone,but didn't know any better. I am so exited to try it out tomorrow!! I love it already, lol. And it AUTO focus's .. too : D
I took these of a Doll (I make and sell reborn dolls) today using my 18-200mm f 3.5-5.6 len and I think they came out real nice. Victoria will be for sale . 6 lbs (feels heavier) fully jointed, anatomical full vinyl body - Ann Fournier Photography (* My mom is a scenic photographer, she is letting me use some albums on her webpages,that's why it has her name*) so with that said,
it will be interesting to see any difference in pictures from this lens, versus the f 3.5-5.6 at 85mm with getting better light into the lens. I bought it for the bokeh, and to be able to get more light. I think the kit lens (18-200) takes kinda crappy pics anyway after 100mm's . Its 10pm at night and around 8/9 when I read the advice above... so I will have to post outside pictures tomorrow ,or monday . But here are a few I took playing around with it tonight :

I think these were all with just the flash (pop up) . I was too lazy to get the speedlight out.
between toy room, and kitchenView attachment 51143
All these taken in the kitchen, or by laundry room View attachment 51144View attachment 51145View attachment 51146View attachment 51147View attachment 51148
Last edited:
I would think an 85/1.8 on a crop sensor would produce some KILLER bokeh when the lens is used properly.
Sharing a photo since some one asked to see pictures,and lastnight it was night,&indoors. Tried taking many (didn't work with my almost 2 yr old) , and got 1 that I think is decent of my almost 16 year old. The only thing I did to it was do "D lighting" (it fixed the slight haze in the picture) . I don't own light room, or photo shop or anything. So the only thing I can do to my pictures are what the ViewNX2 program (that came with my camera) and any in camera processing . So most of my pictures I take are very much like straight out of the camera.

edited to ad one more,from yesterday.
View attachment 51308
Last edited:
I have a 7100 that I've been happily using with an old Nikkor 50/F1.8, non auto focus. I assigned it as my non-CPU lens 1, and it's been working great - aperture shows in viewfinder, takes beautiful pics. Been using it for months. I also use the kit 18-200/F3.5 (good all around lens, but heavy and not that fast), and a Sigma 10-20 (cheap, distorts at 10mm, but really wide and lots of fun to use.)

But my old Nikkor 50 is my go-to lens, until yesterday. The 7100 has stopped "seeing" the aperture settings. I can still take pictures, and the aperture opens and closes, pictures are light or dark, etc, but no metering is going on. Camera reports F11 or F16, however when taking a picture, it's opening or closing the aperture to what I want.

So everything works, but I have to guess at metering for the first couple of pics and then review the image and then adjust from there. Not ideal, and results in missing lots of shots.

Any ideas?
Error message definitions are found on pages 332 - 344 of your D7100 User's Manual.

I'm sorry - was your response a reply to my post? If so, thanks, but there are no error messages in viewfinder or on screen.

The problem is that the camera isn't detecting the aperture setting of my lens (a fully manual lens that's been working beautifully with this camera for six or seven months). Instead, the camera thinks the lens is set at F16.

The lens in question still works great, with my 7100 and my Nikon FM (which I haven't used much since getting the 7100), but I can no longer use aperture-priority mode since the camera doesn't know what the aperture is. Full manual works great, but I have to guess at the first couple of exposures.

Hmmm...maybe I'll dig out another older lens and see if the problem persists. That'll tell me if it's the camera or the lens...

If it's an AI lens then try taking the lens off the camera, set the aperture ring on the lens to f1.8, and then reattach it to the camera. There's a tiny lever on the camera (on the lens mount) that interfaces with the aperture ring on the lens to tell the camera the selected f number of the lens. If that doesn't work it's also possible that this AI lever on the camera is bent or broken.
Yeah, I think that's the problem. The other AI lens behaved the same way, but both AI lens work great on my trusty FM.

After comparing the mounts on the FM and the 7100, I can see that the tiny aperture ring around the mount on the 7100 doesn't seem to be springing back as it should. I can manually position it to a wide open f-stop, then mount the lens, and all is well, and then I can stop down, but the ring on the camera stays put and doesn't spring back when I open up the aperture.

I'll look into getting it fixed after the holidays. The new lenses, while not as fast, work great.

Jeez, that sucks. I've seen plenty of the coupling tabs snap off the ring but I've never heard of the spring mechanism failing. Weird for a new camera.

If it was me, I would take the lens off and twist the ring back-and-forth full travel for awhile in hopes that the spring would magically pop back in place. Of course I'm impatient and my camera is WELL out of warranty so....

Most reactions

New Topics