Trouble With 35mm SLR


TPF Noob!
Dec 24, 2009
Reaction score
New Jersey
Can others edit my Photos
Photos NOT OK to edit
Hi, I have an Olympus iS-50 35mm SLR. Ever since I purchased this camera, which was years ago I have always had difficulty being able to use it! I have tried everything, but for some reason even after it focuses, I receive flashing lights. I'm assuming I need to make adjustments, and so I do, but no matter what, the AF light always stays on. The camera will not allow me to actually take the shot, instead it just continues to focus and refocus. I have tried using the flash as well, and that does not work, so I tried auto, still did not work. In fact it wouldn't even let me use the camera while on auto! I had to turn it on and off a few times. Maybe I have a defective camera? Or am I missing something? I have never had this problem with any other camera, and I am aware of the different adjustments required for each shot depending on lighting. Right now I have ISO 100 Color film. If anyone can give me some insight as to what the problem could be, I would really appreciate it. I would love to get out and start using this camera. I've read great reviews about it, but unfortunately I have not had the same experience as of yet. :(
Here is the manual. It may simply need repair however.
Thanks, I have referred to the manual many times, I will give it a few more tries. If I still can't get it to work I'll take it to see if it needs a repair. I did buy it refurbished, so I suppose it's likely there is a mechanical problem...
make sure the lens aperture ring is set on f22

i know on my D50 the 50mm lens aperture ring would move, now allowing the camera adjust the aperture.

did you try manual focus?

Most reactions

New Topics