Results 1 to 11 of 11
  1. #1
    No longer a newbie, moving up!
    Join Date
    Aug 2006
    Location
    Portadown Northen Ireland
    Posts
    97
    My Gallery
    (0)
    Liked
    0 times

    Sb-600 not firing

    Hope this is in the right section, if not please move it admin.

    right so i got a sb-600 new from amazon a week ago for my Nikon D200 and from the off set it has worked brilliantly up un-till tuesday. where it just stopped working.

    its got all the settings and stuff on the back but its just not firing or making that humming noise when the flash is meant to be recharging i hope you know what i mean. also the 'ready' light on the back of the flashgun does not light up any more tho flashes a few times after i take a picture, even know the flash its self does not fire.

    well after it goes on stand by it says 'bat' which according to the manual is the battery, at the time of starting i had a set of engergiser batteries in, non rechargable 2500's so went out and buy my self a set of rechargable 2500 engergiser's wait till they have charged up and still the same problem the flash shows all the writing and the light works on the flash, even the auto zoom bit works on the flash but its just not charging up and flashing. and the same 'bat' message is coming up when it goes on standby.

    so maybe thinking its the batterys again i buy a set of duracell ultra AA's and still the same problem.

    now ive tried resetting the camera, and looking in the trouble shooting part of the manual, tried turning the standby function off through the buttons on the back of the flash, i have even tried a few settings on my D200 and reset all the settings on that, but still no joy. i have tried different lens also, to see if that makes a button of difference. i may try and see if it works on my friends D50 nikon when i see him at the weekend. but i doubt that will make a diffrence.

    so now im a bit stumpt, all i can think of is something has went in the inside to think what ever batteries i put in are low power or the actual bulb has went, but surely not after a few days of use and possably 150 pics taken.

    if any one can help me that would be so great.
    Last edited by phil-ray; 12-04-2008 at 06:39 PM.



  2. #2
    TPF Junkie!
    Join Date
    Jul 2007
    Location
    State of Confusion
    Posts
    13,385
    My Gallery
    (0)
    My Photos Are NOT OK to Edit
    Liked
    1825 times
    Couple of questions.

    Does it fire when you press the "red" FLASH test button?

    Have you set it to off-camera operation with it on your hotshoe?

    Have you set it to on-camera operation with it off your hotshoe?

    Have you made any adjustments in the Commander mode that may have an affect?

    What mode is your flash set to?


    Could be a bad unit. I've had mine about 2 years without any problems except the one I created.
    The Liver is Evil and Must Be Punished.
    Shooter of FX, DX and MFT

    We boogied in the kitchen
    We
    boogied in the hall
    I got something on my finger
    So I wiped it on the wall

    Chuck Berry - Reelin' and Rockin' - Lancaster Arts Festival 1972

  3. #3
    No longer a newbie, moving up!
    Join Date
    Aug 2006
    Location
    Portadown Northen Ireland
    Posts
    97
    My Gallery
    (0)
    Liked
    0 times
    Hi Kundalini

    it doesnt fire when i try and press the red flash test button, both on and off the camera. (this is kind of worrying me)

    i have tryed putting it in the small stand you get with me and setting the camera to comander mode with no luck in firing the flash also i made sure that the comander settings on the camera are not used, and the option of inbuilt flash is at 'ttl' with the flash at ttl also.

    would it have mattered me trying some settings with it not on the camera. but then resetting the settings useing the reset settings function.?

    on another forum someone said clean the contact points, they dont look dirty but to be honnest i have lost my little cover for the shoe for a while now, ive rubbed it with a microfiber cloth but still no luck.

  4. #4
    TPF Junkie!
    Join Date
    Dec 2007
    Location
    Cincinnati
    Posts
    1,235
    My Gallery
    (0)
    My Photos Are OK to Edit
    Liked
    0 times
    I had a similar problem. I ended up sending it back to Nikon to get serviced.
    Nikon Stuff...

    www.RDphotos.com

  5. #5
    No longer a newbie, moving up!
    Join Date
    Aug 2006
    Location
    Portadown Northen Ireland
    Posts
    97
    My Gallery
    (0)
    Liked
    0 times
    and did they fix it?

    may i ask how much that did cost you?

  6. #6
    TPF Junkie!
    Join Date
    Dec 2007
    Location
    Cincinnati
    Posts
    1,235
    My Gallery
    (0)
    My Photos Are OK to Edit
    Liked
    0 times
    Oh sorry, yes they did fix it. It ended up being like $90 when it was all said and done.
    Nikon Stuff...

    www.RDphotos.com

  7. #7
    No longer a newbie, moving up!
    Join Date
    Aug 2006
    Location
    Portadown Northen Ireland
    Posts
    97
    My Gallery
    (0)
    Liked
    0 times
    umm cheers.

    ive found a nikon repear place in ireland, where i am so i may phone and see if they can help me in some way

    any other ideas welcome

  8. #8
    TPF Junkie!
    Join Date
    Jul 2007
    Location
    State of Confusion
    Posts
    13,385
    My Gallery
    (0)
    My Photos Are NOT OK to Edit
    Liked
    1825 times
    Sorry Dude, but it sounds like you may have a bad specimen. The tell-tale was that the test fire isn't working. I'd contact your sales contact and also Nikon to report a problem.

    Don't worry too much, the SB-600 is a good flash and I'm sure this will be resolved.
    The Liver is Evil and Must Be Punished.
    Shooter of FX, DX and MFT

    We boogied in the kitchen
    We
    boogied in the hall
    I got something on my finger
    So I wiped it on the wall

    Chuck Berry - Reelin' and Rockin' - Lancaster Arts Festival 1972

  9. #9
    TPF Junkie!
    Join Date
    Dec 2007
    Location
    Cincinnati
    Posts
    1,235
    My Gallery
    (0)
    My Photos Are OK to Edit
    Liked
    0 times
    yeah I am very confident that you will get this resolved. The flash is nice. I had a broken bulb...
    Nikon Stuff...

    www.RDphotos.com

  10. #10
    No longer a newbie, moving up!
    Join Date
    Aug 2006
    Location
    Portadown Northen Ireland
    Posts
    97
    My Gallery
    (0)
    Liked
    0 times
    fired an email off to the place I bought it off explaining what's happened and what I've tried to reslove this. I've asked about getting a replacement or would the cover costs if I send it to a repar centre. I'll let u know how I get on

  11. #11
    I spend too much of my life on TPF!
    Join Date
    Jan 2008
    Location
    Atlanta GA
    Posts
    392
    My Gallery
    (0)
    My Photos Are OK to Edit
    Liked
    1 times
    Does Amazon have return policy?
    I am Jack's complete lack of surprise...

    Nikon D80 Nikkor18-55mm, f3.5 Quantaray 70-300mm f4, Nikon 50mm f1.8, Nikon SB600

 

 

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Catching a gun firing
    By inTempus in forum Beyond the Basics
    Replies: 34
    Last Post: 05-12-2010, 03:52 PM
  2. Having firing issues with Sb-900
    By Hooligan Dan in forum Photography Equipment & Products
    Replies: 3
    Last Post: 03-14-2010, 02:08 PM
  3. New 580exII Not Firing
    By murph1 in forum Photography Beginners' Forum
    Replies: 15
    Last Post: 06-18-2009, 12:32 PM
  4. Snap a Gun Firing
    By rob40wilson03 in forum Beyond the Basics
    Replies: 20
    Last Post: 04-10-2008, 12:19 PM
  5. Firing Squad
    By LizM in forum General Gallery
    Replies: 3
    Last Post: 11-06-2005, 05:09 PM

Search tags for this page

bat on 600 flash
,

nikon sb 600 troubleshooting

,

nikon sb600 not firing

,
sb 600 bat
,

sb 600 does not fire

,
sb-600 does not flash
,

sb-600 not flashing

,
sb600 not flashing
Click on a term to search for related topics.