Af assist bean with the 580m2

Discussion in 'Beyond the Basics' started by Overread, Jul 26, 2008.

  1. Overread

    Overread has a hat around here somewhere Staff Member Supporting Member

    Joined:
    May 1, 2008
    Messages:
    23,087
    Likes Received:
    3,756
    Location:
    UK - England
    Can others edit my Photos:
    Photos OK to edit
    Ok I have a speedlite 580M2 and a canon 400D - now in the instructions for the speedlite it says that it will fire automatically, an assistance beam for focusing in dark situations. However I cannot seem to get mine to fire in any mode but Green P mode - in all the others it remains dead when in the same conditions. This is a problem if I want to shoot in anything but P mode - anyone got any advice?
     
  2. RyanLilly

    RyanLilly No longer a newbie, moving up!

    Joined:
    Aug 27, 2007
    Messages:
    1,478
    Likes Received:
    8
    Location:
    St. Louis, Missouri, USofA
    Can others edit my Photos:
    Photos NOT OK to edit
    check you custom functions menu on your camera, At least its under custom functions on a 20D, There are settings like "flash fires" or "flash does not fire" and turning on or off the AF assist.
     
  3. Overread

    Overread has a hat around here somewhere Staff Member Supporting Member

    Joined:
    May 1, 2008
    Messages:
    23,087
    Likes Received:
    3,756
    Location:
    UK - England
    Can others edit my Photos:
    Photos OK to edit
    ahh I got it thanks Ryan! :)
    I checked the custom menu and it was set to emit - so nothing was wrong there, but I went back and checked the auto modes and it would work in them all barring no flash and also sports mode. I tried to work out why then realised - it was aiservo mode for focusing. It only emits for single shot and ai focusing and not servo mode!
     

Share This Page

Search tags for this page

canon flash assist bean servo