Blemish issue with Canon SX10IS

Discussion in 'Digital Discussion & Q&A' started by torypaulsmith, Nov 22, 2009.

  1. torypaulsmith

    torypaulsmith TPF Noob!

    Joined:
    Nov 22, 2009
    Messages:
    1
    Likes Received:
    0
    Location:
    Blacksburg, VA
    Can others edit my Photos:
    Photos OK to edit
    Hello Everyone,

    I have a Canon Powershot SX10IS (fantastic camera) that is almost a year old now. I've taken about 2000 pictures with it, and I am just now having an issue with it for the first time.

    I went out a few weeks ago to take some pictures and about halfway through I noticed a blemish that was recurring in each photograph. I thoroughly cleaned the lens with a microfiber cloth and kept shooting, but the blemish was still there. It doesn't appear to be on the outer surface of the lens, so I don't know where it came from.

    Below is a picture with the blemish in it:

    Picasa Web Albums - Tory

    The blemish is the translucent, hexagonal shape in the upper left-hand corner. I should note that it is also visible when I am taking the pictures. The blemish changes size when I focus.

    Does anyone know what this is or how I can fix it?

    Thanks,
    Tory
     
  2. lvcrtrs

    lvcrtrs TPF Noob!

    Joined:
    Dec 18, 2008
    Messages:
    606
    Likes Received:
    1
    Location:
    Pennsylvania
    Can others edit my Photos:
    Photos OK to edit
    I see it, but don't know what to tell you. If you have cleaned the lens, i'd think it's something internal. How about a all to Canon?
     

Share This Page

Search tags for this page

blemish issue

,

canon photo blemish