Help with a 35mm Canon T50

Discussion in 'Photography Beginners' Forum' started by KAikens318, Aug 28, 2009.

  1. KAikens318

    KAikens318 TPF Noob!

    Joined:
    Jun 6, 2009
    Messages:
    933
    Likes Received:
    19
    Location:
    Manchester, NH
    Can others edit my Photos:
    Photos OK to edit
    Hi everyone!

    I just picked up a Canon T50 and I am having a little problem with it, was wondering if anyone knew anything about them. I have brand new batteries, the camera acknowledges that they are in there and working, but once I load the film, I push the shutter button as that is supposed to advance the film to the number '1' but it goes nowhere so I can't take pics. Any ideas?
     
  2. Dwig

    Dwig TPF Noob!

    Joined:
    Mar 11, 2009
    Messages:
    1,261
    Likes Received:
    0
    Location:
    Key West FL
    Can others edit my Photos:
    Photos NOT OK to edit
    It sounds like a malfunction in the transports, but there are a few thing to check:

    1. Is the rewind button depressed or has it popped out to its normal advance position? If not, wiggle the sprocket wheel a bit to see if it will pop out.

    2. Make sure you are loading the film correctly as illustrated in the manual.

    3. Double check that the batteries are truly good enough by using the battery check function (pg 10 in the manual). Perhaps, try another set.

    Free PDF manual available at:
    Canon t50 instruction manual, user manual, PDF manual, free manuals
    (if the manual helps, considere making a donation to their site)
     
  3. KAikens318

    KAikens318 TPF Noob!

    Joined:
    Jun 6, 2009
    Messages:
    933
    Likes Received:
    19
    Location:
    Manchester, NH
    Can others edit my Photos:
    Photos OK to edit

    Thanks. I have done all of the above and nothing is working so far. Contacted Canon but they weren't much help as they simply told me how to load the film even though I know how to do that. Hopefully I will find something that works, hoping that it's not the motor or something, would really like to use the camera~!
     

Share This Page

Search tags for this page
canon t50 beeping
,
canon t50 help
,
canon t50 motor not advancing
,
canon t50 problems
,
canon t50 shutter problems
,

canon t50 troubleshooting

,
canon t50 wont load film
,
canont50 beeping
,
clicking sound canon t50 wont load film
,
how to take out film of a canon t50