Fuji Finepix F30 burning smell now won't function.

Discussion in 'Off Topic Chat' started by RBCONDO, Feb 20, 2007.

  1. RBCONDO

    RBCONDO TPF Noob!

    Joined:
    Feb 3, 2007
    Messages:
    11
    Likes Received:
    0
    Location:
    Rehoboth Beach Delaware
    Can others edit my Photos:
    Photos OK to edit
    I lost the USB cable for my Fuji Finepix F30 on vacation and ordered a new one on ebay. I plugged it in to get my vacation shots off the camera and smelled a burning odor.

    The photos never transfered. Photoshop never opened and asked me if I wanted to transfer my pictures and the USB controller told me it had found a device that it did not recognize.

    Now the camera LCD screen will not display anything at all.

    I'm guessing the Ebay USB cable just fried my camera.

    Any suggestions would be greatly appreciated.

    This is not my primary camera but it makes (made) a nice back up when I just need snap shots.
     
  2. mrsid99

    mrsid99 TPF Supporters Supporting Member

    Joined:
    Mar 8, 2003
    Messages:
    2,964
    Likes Received:
    5
    Location:
    Florida
    Pure guess on my part but it's possible they swapped the +5v and gnd/common wires in the USB cable.
    That would account for the expensive smells.
    To fix it, you're gonna hafta get the electrical smoke replaced since you carelessly let it out.
    You do have my condolences for what it's worth.
     

Share This Page

Search tags for this page

fuji finepix s3 pro burnt smell