GX7 on-camera flash

Discussion in 'Panasonic Cameras' started by Clay Olmstead, Jun 13, 2015.

  1. Clay Olmstead

    Clay Olmstead TPF Noob!

    Joined:
    Feb 15, 2015
    Messages:
    40
    Likes Received:
    7
    Location:
    Austin, TX
    I've noticed that when I use the on-camera flash on my GX7, the JPGs come out with a weird look to them. Everything in the picture looks like it was made out of wax, or plastic. I've owned lots of cameras: film and digital, big and small, and I've never seen this before.

    I realize this isn't the mode I would use to get the best results. It's strictly for snapshots, family pix and so on. Still, I would like to be happy with the results.

    Has anybody else noticed this? If not, I'll post some examples to show what I mean. If you have, what have you done about it? Should I shoot RAW (and upgrade Lightroom - grumble, grumble); use only off-camera flash (and carry it everywhere - more grumbling); or use some sort of flash modifier?


     
  2. Tinderbox (UK)

    Tinderbox (UK) No longer a newbie, moving up!

    Joined:
    May 1, 2010
    Messages:
    739
    Likes Received:
    119
    Location:
    England
    Can others edit my Photos:
    Photos OK to edit
    Turn the electronic shutter off and see if that helps.

    John.
     
  3. Clay Olmstead

    Clay Olmstead TPF Noob!

    Joined:
    Feb 15, 2015
    Messages:
    40
    Likes Received:
    7
    Location:
    Austin, TX
    Good idea, but I didn't have the electronic shutter on at the time.
     
  4. Tinderbox (UK)

    Tinderbox (UK) No longer a newbie, moving up!

    Joined:
    May 1, 2010
    Messages:
    739
    Likes Received:
    119
    Location:
    England
    Can others edit my Photos:
    Photos OK to edit
    I have had a couple of GX7 camera`s and have not had this problem, can you post an example photo?

    John.
     
  5. Clay Olmstead

    Clay Olmstead TPF Noob!

    Joined:
    Feb 15, 2015
    Messages:
    40
    Likes Received:
    7
    Location:
    Austin, TX
    Here's a good example. I'll set up one that's with/without flash for the same scene. P1200236.JPG
     
  6. Tinderbox (UK)

    Tinderbox (UK) No longer a newbie, moving up!

    Joined:
    May 1, 2010
    Messages:
    739
    Likes Received:
    119
    Location:
    England
    Can others edit my Photos:
    Photos OK to edit
    Yeah, it`s the direct flash that is causing the problem.

    Try and diffuse the light, do a bit of diy with an milk container and make your own diffuser, depending on the high and color of the ceiling, you can pull the GX7 flash back a bit and bounce the light off the ceiling.

    If that does not work, you really need a good external flash.

    John.
     
  7. Clay Olmstead

    Clay Olmstead TPF Noob!

    Joined:
    Feb 15, 2015
    Messages:
    40
    Likes Received:
    7
    Location:
    Austin, TX
    A milk carton - that's a great idea! I thought about flash modifiers, but I didn't want to spend the money just as an experiment. I'll try that.

    I knew about the trick of pulling the flash back with your finger. I worked up a little Velcro strap so it stays down and I can cup my hand behind it for a reflector. That works a lot of times, and it's a huge improvement, but the little flash isn't powerful enough for that to work all the time.
     
  8. Tinderbox (UK)

    Tinderbox (UK) No longer a newbie, moving up!

    Joined:
    May 1, 2010
    Messages:
    739
    Likes Received:
    119
    Location:
    England
    Can others edit my Photos:
    Photos OK to edit
    Hi.

    The bright sky above the peoples heads in the photo most likely caused the camera to underexpose that is why the photo is dark, if the exposure was set to area mode, the built inflash can help a bit for backlit subjects, but if you select spot metering and take a reading on one of the faces the camera will do the exposure correctly.

    John.
     
  9. Clay Olmstead

    Clay Olmstead TPF Noob!

    Joined:
    Feb 15, 2015
    Messages:
    40
    Likes Received:
    7
    Location:
    Austin, TX


    It's fixed now - pretty easy, actually. I had turned the flash exposure down to -1 2/3 stops and forgot to change it back. When I turned it up to 0 and set WB on flash, it worked perfectly - now it points up the fact that I need a better model than my ugly mug, but the camera can't help me there. Thanks for your help, John! You led me in the right direction.
    P1260617.jpg
     

Share This Page