Strobe synch

Discussion in 'Fujifilm Cameras' started by fmw, May 11, 2017.

  1. fmw

    fmw No longer a newbie, moving up!

    Joined:
    Sep 30, 2006
    Messages:
    3,597
    Likes Received:
    465
    My new X-A3 arrived today. Terrific product. My main purpose for the camera is shooting product photos for my web sites. I use a light tent that is lit with a pair of Bowens monolights. I was unable to get the camera to fire the strobes. What do I need to do to get the camera to synch and fire the strobes?


     
  2. tirediron

    tirediron Watch the Birdy! Staff Member Supporting Member

    Joined:
    Jul 8, 2005
    Messages:
    40,497
    Likes Received:
    12,229
    Location:
    Victoria, BC
    Can others edit my Photos:
    Photos OK to edit
    Pretty much any radio trigger will work. You can get a PC adaptor for the hot shoe and use that (cheap, but a major PIA), or set the slave flash receive on the lights and use a speedlight in the hot shoe.
     
  3. fmw

    fmw No longer a newbie, moving up!

    Joined:
    Sep 30, 2006
    Messages:
    3,597
    Likes Received:
    465
    My hot shoe adapter isn't working with this camera for some reason. The last thing I want to do is trigger the strobes with an on camera flash.
     
  4. tirediron

    tirediron Watch the Birdy! Staff Member Supporting Member

    Joined:
    Jul 8, 2005
    Messages:
    40,497
    Likes Received:
    12,229
    Location:
    Victoria, BC
    Can others edit my Photos:
    Photos OK to edit


    Are you using a hot shoe PC Sync adaptor? If so, try another one. Best bet however is an inexpensive set of radio triggers. Yongnuo & similar decent-quality MiC gear can be had for <$100 (probably a lot less).
     

Share This Page