Harddrive access problems - formatting

Discussion in 'Photography Equipment & Products' started by Overread, Feb 17, 2012.

  1. Overread

    Overread has a hat around here somewhere Staff Member Supporting Member

    Joined:
    May 1, 2008
    Messages:
    25,169
    Likes Received:
    4,735
    Location:
    UK - England
    Can others edit my Photos:
    Photos OK to edit
    Ok so my harddrive has decided to half break itself. I did try googling and got loads of product sales pages...


    Basically the computer reads that the drive is connected and displays it in My Computer, but each time I try to access it it asks me to format the drive before it will open. Now I assume if I format the drive all the data links will be lost and that I'll then have to shell out for a recovery software option to restore them. I can't try connecting it to another computer as I don't have one - furthermore the data on the drive is larger than I've got spare backup space for so I can't do any fancy drive mirroring or anything.

    And finally - yes its one-time copies of info on the drive - I've backups of much of the older stuff, but some of the newer isn't backed up so there is data on the drive I want to access.


    Soo erm - help please :)
    Is there any way to access it without formatting? Or have I got to get one of these software recovery programs (I should have some Sandisk restoration software around here which comes with their memory cards - though I'm unsure if that is suitable for harddrives).


     
  2. NickA

    NickA TPF Noob!

    Joined:
    Jan 3, 2012
    Messages:
    121
    Likes Received:
    16
    Location:
    NY
    Can others edit my Photos:
    Photos OK to edit
    It's an external hard drive, connected via USB?
     
  3. Overread

    Overread has a hat around here somewhere Staff Member Supporting Member

    Joined:
    May 1, 2008
    Messages:
    25,169
    Likes Received:
    4,735
    Location:
    UK - England
    Can others edit my Photos:
    Photos OK to edit
    Yes, external and USB connected.
     
  4. NickA

    NickA TPF Noob!

    Joined:
    Jan 3, 2012
    Messages:
    121
    Likes Received:
    16
    Location:
    NY
    Can others edit my Photos:
    Photos OK to edit
    Try a different cable and USB port. Mine did the same thing (it's a Maxtor). The cable carries power to the drive as well. In my case, I would get the error you have, but sometimes it would connect. Tried a new cable and it worked. If you use a different cable, make sure it's the type that can supply enough power to the drive as well.

    Can you hear it spin when you plug it in?
     
    • Like Like x 1
  5. Overread

    Overread has a hat around here somewhere Staff Member Supporting Member

    Joined:
    May 1, 2008
    Messages:
    25,169
    Likes Received:
    4,735
    Location:
    UK - England
    Can others edit my Photos:
    Photos OK to edit
    Hmm the drive has its own mains power supply as well as the USB. I've tried changing to a different cable, and also pulled out both cables from the drive before putting them back in. I can hear the drive spinning up, but sadly the computer still wants to format it.
     
  6. NickA

    NickA TPF Noob!

    Joined:
    Jan 3, 2012
    Messages:
    121
    Likes Received:
    16
    Location:
    NY
    Can others edit my Photos:
    Photos OK to edit
    Try running chkdsk from the command prompt and see if it reads it. There is a /r and /f switch you can try to recover and fix errors, but just try chkdsk first to see if it's healthy.
     
  7. cgipson1

    cgipson1 TPF Noob!

    Joined:
    Aug 18, 2011
    Messages:
    17,144
    Likes Received:
    4,355
    Can others edit my Photos:
    Photos NOT OK to edit
    ^ this! Sounds like a corupt FAT table... Chkdsk will probably fix it....
     
  8. SCraig

    SCraig Been spending a lot of time on here!

    Joined:
    Nov 12, 2011
    Messages:
    6,474
    Likes Received:
    2,443
    Location:
    Nashville, TN
    Can others edit my Photos:
    Photos NOT OK to edit
    What he said. There are normally two copies of the FAT (file allocation table) so that when / if one becomes corrupted it can be replaced with the other. Give CHKDSK a try.
     
  9. table1349

    table1349 Been spending a lot of time on here!

    Joined:
    Sep 9, 2006
    Messages:
    0
    Likes Received:
    4
    If CHKDSK does not fix it, find a friend with a Mac. OSX reads fat files a bit differently. If it is NTFS then it will be read only but they should be able to copy the files you want onto another media. I would do this as the last resort but it is worth the try if nothing else works.
     
  10. Josh66

    Josh66 Been spending a lot of time on here!

    Joined:
    Oct 31, 2007
    Messages:
    14,604
    Likes Received:
    1,238
    Location:
    Cedar Hill, Texas
    Can others edit my Photos:
    Photos NOT OK to edit
    When you're done using it, do you just unplug it or do you right click it and select 'safely remove drive'? Sometimes stuff like this can happen if you remove it while it's still working. You should always right click it and safely remove it to ensure that whatever it is doing is done before you unplug it. Same goes for thumb drives and stuff like that.
     
  11. Overread

    Overread has a hat around here somewhere Staff Member Supporting Member

    Joined:
    May 1, 2008
    Messages:
    25,169
    Likes Received:
    4,735
    Location:
    UK - England
    Can others edit my Photos:
    Photos OK to edit
    This drive is pretty much left on the whole time the computer is active, its basically used just like an internal only its external - and thanks for the advice all chkdisk fixed it up :)

    Now just gonna go update my backups to be sure!
     
  12. cgipson1

    cgipson1 TPF Noob!

    Joined:
    Aug 18, 2011
    Messages:
    17,144
    Likes Received:
    4,355
    Can others edit my Photos:
    Photos NOT OK to edit


    good! Glad to hear it! :)
     

Share This Page