Help! Canon 60D and wireless flash triggers

Davis5

TPF Noob!
Joined
Sep 22, 2015
Messages
1
Reaction score
0
Can someone please offer some help/advice. I have a Canon 60D that I use with an older light set up that I've had for probably 8 or more years (studio max III 320 by photogenic). Photography is just a hobby so most things are trial and error for me. I recently purchased a set of Yongnuo RF-603C II wireless flash triggers.. Hoping to get rid of the sync cord and hot shoe set up I've been using. Not sure what I'm doing wrong but I cannot get the triggers to work! Seems to work with the lights and will test fire but once I hook up to my camera... Nothing! Is there a setting I'm missing, a different cord I need or are they just not compatible? If anyone can help, I would be very grateful!
 

Dao

No longer a newbie, moving up!
Joined
Mar 24, 2008
Messages
6,423
Reaction score
462
Location
St. Louis
First, make sure the batteries in the unit have charge. In the past, some of those flash triggers shipped with batteries with little charge left. It worked, but not enough to work properly.

Make sure the unit that mount on the camera hot shoe is set to TX as Transmitter while the one with the flash set to TRX as receiver.

According to the description I read online, it should work with the 60D (or any cameras that use standard hot shoe with the center pin).
 

JacaRanda

Hobbyist Birdographer
Joined
Mar 20, 2012
Messages
5,472
Reaction score
2,600
Location
Orange County California
Can others edit my Photos
Photos OK to edit
Are you able to post a camera phone shot of the setup?
The triggers are transceivers so there is no setting for transmit or receive.

Here is a quick video (using a speed light)
 
Last edited:

beagle100

Been spending a lot of time on here!
Joined
Mar 31, 2015
Messages
2,068
Reaction score
539
Can others edit my Photos
Photos OK to edit
Can someone please offer some help/advice. I have a Canon 60D that I use with an older light set up that I've had for probably 8 or more years (studio max III 320 by photogenic). Photography is just a hobby so most things are trial and error for me. I recently purchased a set of Yongnuo RF-603C II wireless flash triggers.. Hoping to get rid of the sync cord and hot shoe set up I've been using. Not sure what I'm doing wrong but I cannot get the triggers to work! Seems to work with the lights and will test fire but once I hook up to my camera... Nothing! Is there a setting I'm missing, a different cord I need or are they just not compatible? If anyone can help, I would be very grateful!

I use the older yongnuo RF 601 wireless manual triggers with a 60D and Yongnuo and Canon flashes but don't know about the 'Studio Max' lights
 

Most reactions

New Topics

Top