"Local Disk" as Image.


TPF Noob!
Feb 6, 2012
Reaction score
Wellington, New Zealand
Can others edit my Photos
Photos OK to edit
Hey guys, I'm just new to this site and thought I'd start off by asking wheter or not any of you have encountered the following before. After going out and taking some pictures tonight I returned home to copy the images over to my computer to find that all of the raw files had showen up as "Local Disk". I took a screenshot to show you all what I mean:


To me this seems rather odd.. I don't want to format them right away incase someone has a fix for this, but I have the JPG's so if need be I can.

Any advice or conclusions would be greatly welcomed.


Right click on a file, then choose "Properties". What does it say?
It would seem that after removing and re inserting the SD card, I can now see the CR2 files. But when I did right click on them earlier it just showed an empty file: 0kbs, no information. I suppose this is solved though.

Question: What do you do when your files show up as "Local Disk"?
Answer: Turn your camera off and on again. Clean SD card.

Fancy that :p
First, try the old Windows 'stand by' fix...shut everything down normally and try again. One off-the wall consideration is that your Windows 7 computer isn't up to date. Or, it could be a case of the wrong device-driver for the your 60D.

If all else fails, find a SD card reader and use that to read the memory card. It reads a lot faster than using the wire to the 60D.

EDIT: I don't know how to do it under Windows 7, but check the file type handling. In Windows XP, while viewing a directory, click 'tools', 'folder options' tab, then 'file types' tab and see what it shows for CR2 files. It might be as simple as correcting the CR2 handling to point to the correct program.

Most reactions