Need Help with Minolta X-700

Discussion in 'Collector's Corner' started by sarahz123, Mar 2, 2017.

  1. sarahz123

    sarahz123 TPF Noob!

    Joined:
    Mar 2, 2017
    Messages:
    1
    Likes Received:
    0
    Can others edit my Photos:
    Photos NOT OK to edit
    I just purchased a Minolta X-700. I put new batteries in, and everything worked for exactly one shot (the shutter fired, and I could even hear the beeping of the meter). But after that, the lever would advance but the shutter wouldn't fire. If I turned the camera off and on, it fires exactly once before quitting again. What's up here? I've tried using an eraser on the battery area, etc. Why does it only work once?


     
  2. dxqcanada

    dxqcanada Been spending a lot of time on here!

    Joined:
    Dec 4, 2008
    Messages:
    7,018
    Likes Received:
    1,258
    Location:
    Woodbridge, Ontario, Canada
    Can others edit my Photos:
    Photos OK to edit
    Are you sure the battery is new ?
     
  3. dasmith232

    dasmith232 TPF Supporters Supporting Member

    Joined:
    Mar 14, 2012
    Messages:
    195
    Likes Received:
    83
    Location:
    Colorado
    Can others edit my Photos:
    Photos OK to edit
    I have a couple of those bodies and love them! After reading your post, I tried to duplicate what you might be running into (and not necessarily successfully), but...

    Make sure you're advancing the lever completely. I can mimic what you're describing by just barely coming up short on advancing the lever.

    There are two sprockets/spools on the take-up side inside the film area that have some mechanical interlock with the main advance lever. There's a tiny silver button on the bottom plate (to allow rewinding the film) press it in completely but don't rewind the film. Try releasing the shutter after pressing that.

    The only other idea I have is there's one more control that's tied into the electronics, and that's the AEL/ST button on the front face of the camera, near where your middle finger of your right hand would be. Try cycling that up and down a time or two and then make sure it's back in the middle position.

    I don't have any other ideas at the moment. But if you have any more symptoms after trying these things, maybe we can come up with more ideas.
     
  4. cgw

    cgw No longer a newbie, moving up!

    Joined:
    Feb 27, 2013
    Messages:
    1,666
    Likes Received:
    372
    Location:
    Toronto
    Baked-in defect.Bum capacitors. Had two, both succumbed to the same problem. Lots of online amateur surgery tutorials that deal with the issue.
     
    • Informative Informative x 2
  5. dasmith232

    dasmith232 TPF Supporters Supporting Member

    Joined:
    Mar 14, 2012
    Messages:
    195
    Likes Received:
    83
    Location:
    Colorado
    Can others edit my Photos:
    Photos OK to edit


    Guess I got lucky! Never had a problem with either of mine and I think I owned/used that body longer than any other body. (Not more shutter counts, but longer time.)
     

Share This Page