x700 problem

niccig

TPF Noob!
Joined
Jun 4, 2006
Messages
276
Reaction score
0
Location
Lexington, KY
Website
www.niccigilland.com
Can others edit my Photos
Photos OK to edit
Hi everyone. I have a problem- I ebayed for a a used Minolta x700, and got it yesterday. It looked great and everything seemed to be fine, but when I got some film this morning and tried to load it I ran into some trouble. When I try to load the film, the film advance arm won't swing all the way out. The manual says if this happens, to release the shutter and the film arm will operate normally. However, when I press the shutter release, nothing happens! The seller has already agreed to take the camera back and refund my money if I can't get it to work, but I figured I'd try here before I send it back. So what do you all think - should I bother trying to fix it, or is it a dud? Thanks!
 

PlasticSpanner

TPF Noob!
Joined
May 1, 2005
Messages
4,125
Reaction score
51
Location
Cheshire, England
Website
www.CheshireCatCarClub.Info
Can others edit my Photos
Photos NOT OK to edit
Does the shutter work OK if you take the film out and close the back?

I used to have a problem with my X300 but cured it by setting the shutter speed to 1/60th whenever I changed the film. (which I now do on all my manual cameras)

Another thing to check is the timer switch. Not sure if it's still the same as my X300 but it's located to the left of the lens (if you're looking at the camera from the wrong side! :lol: ) Up turns the timer on and pressed & held down is the DOF preview.
 
OP
niccig

niccig

TPF Noob!
Joined
Jun 4, 2006
Messages
276
Reaction score
0
Location
Lexington, KY
Website
www.niccigilland.com
Can others edit my Photos
Photos OK to edit
No, the shutter won't work at all. The time switch is off. I tried setting it to 1/60 like you said, but that didn't work either :-( Thanks.
 
OP
niccig

niccig

TPF Noob!
Joined
Jun 4, 2006
Messages
276
Reaction score
0
Location
Lexington, KY
Website
www.niccigilland.com
Can others edit my Photos
Photos OK to edit
Thanguys. I used brand new batteries (that was my first thought), and the mirror is ok. I spent a couple hours looking for more info on this type of problem, and apparently the capacitors that run the shutter have a habit of failing. I suspect this is the problem, though I don't think I'll take the camera apart to look, just send it back. And I was so excited about it, too.....
 

Most reactions

Top