Yashica Quartz FX-D mirror stuck

Discussion in 'Film Discussion and Q & A' started by mub15rl, Oct 9, 2018.

  1. mub15rl

    mub15rl TPF Noob!

    Joined:
    Oct 9, 2018
    Messages:
    2
    Likes Received:
    0
    Hi!

    I took a photo with my Yashica Quartz FX-D and the mirror never came down. The wind on lever is stuck and won't move forward and although I can push the capture button down, no picture is taken.

    The mirror is definitely not stuck up because it's gummy, I took it to the repair shop and they said it's the mirror mechanism, but the quote of £75 is too expensive for me.

    Does anyone know how to fix this at home? I've tried removing the bottom of the camera but everything seems fine..

    Please help! Thank you!


     
  2. cgw

    cgw Been spending a lot of time on here!

    Joined:
    Feb 27, 2013
    Messages:
    1,985
    Likes Received:
    502
    Location:
    Toronto
    Fresh batteries? Check for an online manual, too.
     
  3. mub15rl

    mub15rl TPF Noob!

    Joined:
    Oct 9, 2018
    Messages:
    2
    Likes Received:
    0
    Unfortunately not the batteries, tried that! Can't seem to find a repair manual anywhere and it's not discussed in the user manual.
     
  4. dxqcanada

    dxqcanada Been spending a lot of time on here!

    Joined:
    Dec 4, 2008
    Messages:
    7,494
    Likes Received:
    1,481
    Location:
    Woodbridge, Ontario, Canada
    Can others edit my Photos:
    Photos OK to edit


    If the battery lacked enough power during the last shot it may not reset the mechanisms (just a theory of mine), so put in a new battery and give the camera a hard slap on the bottom ... my theory is that the camera thinks the shutter has not completed its cycle, so causing the shutter to move will trip whatever sensor/mechanism into thinking everything is done.
    This is something I have done in the past when customers brought in cameras in this condition ... sometimes I have had to manually pull the shutter curtain and quickly release it to do this (you actually have to use one finger on both hands to grasp the shutter on both sides ... though this is much easier to do with a horizontal shutter than a multi-bladed vertical one as you can pop the blades out of the slots).
     

Share This Page

Search tags for this page
yashica fx d mirror problem
,

yashica fx-d mirror lock up

,
yashica fx-d mirror stuck
,
yashica fx-d quartz repair manual
,
yashica quartz mirror problem