help! advanc film, shutter closes

Discussion in 'Photography Beginners' Forum' started by c0rpse, Oct 22, 2006.

  1. c0rpse

    c0rpse TPF Noob!

    Joined:
    Oct 22, 2006
    Messages:
    2
    Likes Received:
    0
    I am relatively new to photography and im having a problem! im using a pentax k1000 and iv had no problems since i'v had it. recently when i advance the film, the shutter closes and i cant see anything out the view finder. it appears as though the pictures are still working but i cant see anything.

    am i doin something wrong? i think it might be the lense because i tried a telephoto for a few shots and i didnt do it...but i cant say forsure.

    also, the issue seems a tad intermittent...out of about 15 shots i think i could see out the viewfinder about 4 times.

    any ideas? is it my camera? my lense? me?
     
  2. mysteryscribe

    mysteryscribe TPF Noob!

    Joined:
    Feb 1, 2006
    Messages:
    6,071
    Likes Received:
    3
    Location:
    in the middle of north carolina
    Can others edit my Photos:
    Photos OK to edit
    sounds like your mirror isnt returning.... that would be in the camera body but wait and get some more opinions...
     
  3. c0rpse

    c0rpse TPF Noob!

    Joined:
    Oct 22, 2006
    Messages:
    2
    Likes Received:
    0
    I made a mistake in my original post. When I advance the film the aperture is closing down all the way, not the shutter.
     
  4. W.Smith

    W.Smith TPF Noob!

    Joined:
    Oct 11, 2006
    Messages:
    440
    Likes Received:
    0
    I agree with mysteryscribe: your mirror is probably not returning.
    I wonder if it'll be worth it to have it repaired. Get a quote first.
     

Share This Page