Canon 50D Trouble Please Help

abrewerphotography

TPF Noob!
Joined
May 24, 2009
Messages
17
Reaction score
0
Location
KY
Website
www.abrewerphotography.com
Can others edit my Photos
Photos NOT OK to edit
I have a canon 50 d that is only 2 months old. I have been having trouble when using it in auto that the flash will not pop up, and in the image produced is all black. Also when I go into av or the other modes it does the same thing. I am getting only black images, and if the flash does pop up when I manually push the button, the image is still very dark. Any suggestions? I am so frustrated b/c this is a virtually brand new camera!
 

Dao

No longer a newbie, moving up!
Joined
Mar 24, 2008
Messages
6,426
Reaction score
462
Location
St. Louis
OP, what about when you take photos during the day (outdoor)?
 

NateWagner

TPF Noob!
Joined
Jun 2, 2008
Messages
1,236
Reaction score
0
Location
St. Petersburg, FL
Website
www.loneoakphotography.com
Can others edit my Photos
Photos OK to edit
yeah, wasn't thinking... lens cap.

Also, when you go into auto are you talking about the P mode, or the green box?

one other thing to check is when in AV do you have exposure compensation at even? or is it way into the negative range?
 

sinjans

TPF Noob!
Joined
Jun 29, 2009
Messages
346
Reaction score
0
Location
Newfoundland, Canada (yes by')
Can others edit my Photos
Photos OK to edit
have you reset your settings to default yet? if it wont pop up when it is supposed to i.e. green mode, or portrait in less lighting then it probably needs to be sent to canon.


(EDIT) also what lens do you have on it? is their a round alert light going off in the view finder?
 

Crosby

TPF Noob!
Joined
Mar 7, 2008
Messages
269
Reaction score
0
Location
Arkansas
Can others edit my Photos
Photos OK to edit
OP, Have you read the book?
 

William Petruzzo

TPF Noob!
Joined
Aug 22, 2008
Messages
635
Reaction score
2
Location
Washington DC
Website
www.petruzzo.com
Can others edit my Photos
Photos OK to edit
If you're not getting an error notification, I'd bet there's a setting somewhere you're missing. I'd try resetting to defaults, then spending an afternoon studying the manual to the last drop.

If that takes you nowhere, off to Canon it is!
 

Most reactions

Top