Canon EOS A2e will not advance film...Please help!!!!

Discussion in 'Photography Equipment & Products' started by cheezit, Apr 7, 2007.

  1. cheezit

    cheezit TPF Noob!

    Apr 7, 2007
    Likes Received:
    Can others edit my Photos:
    Photos OK to edit
    I hope that this topic has not already been posted...if it has then i am sorry but i did some extensive searching.

    If anyone has any experience with the Canon EOS A2e i am in need of your help. My A2e out of nowhere decides that it doesnt want to advance the film. First thing i tried was to replace the battery and it worked for that day. A few days later i loaded some film and proceeded on to my photo shoot and when i got focused in i clicked half way to focus and my internal meter starts to freak out and give me outrageous shutter speeds and aperture settings, The first one it gave me was 1/60 and f.00 the next was 1/125 and f.00, i was fine with the 1/125, but weary of the f.00, so i clicked all of the way and i heard the shutter open and it didnt close. At this point the LCD display went blank except for the battery symbol and it was flashing ISO. So i realize taht something is wrong and decide click the shutter button and as soon as i clicked it the shutter closed, but the film did not advance, and it keeps on doing the same thing.

    If anyone understands what i just said and thinks they can help please let me know because i really would like to not take it somewhere and spend the little money that i have.

    Much thanks...


Share This Page