Canon T1i - Autofocus Issue

mr.mike

TPF Noob!
Joined
May 7, 2013
Messages
133
Reaction score
12
Location
S.E.
Can others edit my Photos
Photos NOT OK to edit
Hi,
I have a Canon T1i and the autofocus feature is not working. Manual focus is fine. I've tried other lenses but none work. Current lens is the standard EF 18-55. This lens works just fine on my EOS film camera. I would appreciate your thoughts.
Thank you,
Mike
 

jcdeboever

Been spending a lot of time on here!
Joined
Sep 5, 2015
Messages
19,866
Reaction score
15,919
Location
Michigan
Can others edit my Photos
Photos OK to edit
Hi,
I have a Canon T1i and the autofocus feature is not working. Manual focus is fine. I've tried other lenses but none work. Current lens is the standard EF 18-55. This lens works just fine on my EOS film camera. I would appreciate your thoughts.
Thank you,
Mike
Check this link to trouble shoot. Hope it helps you.
AF (Autofocus) does not work (EOS REBEL T1i / EOS 500D)

Sent from my XT1254 using Tapatalk
 

AKUK

No longer a newbie, moving up!
Joined
Feb 1, 2015
Messages
344
Reaction score
266
Location
Kent, United Kingdom
Can others edit my Photos
Photos NOT OK to edit
You could try cleaning the electrical contacts with Q-tips and rubbing alcohol to see if that makes a difference. Remove the camera battery first.
 
OP
M

mr.mike

TPF Noob!
Joined
May 7, 2013
Messages
133
Reaction score
12
Location
S.E.
Can others edit my Photos
Photos NOT OK to edit
Hi,
I have a Canon T1i and the autofocus feature is not working. Manual focus is fine. I've tried other lenses but none work. Current lens is the standard EF 18-55. This lens works just fine on my EOS film camera. I would appreciate your thoughts.
Thank you,
Mike
Check this link to trouble shoot. Hope it helps you.
AF (Autofocus) does not work (EOS REBEL T1i / EOS 500D)

Sent from my XT1254 using Tapatalk

Thank you,
I have my camera set exactly as this page indicates. However, it seems my camera will not operate at all when placed in full auto function. If I select the program mode, shutter will fire, but the autofocus feature will not work. Also, if I select the auto lock feature, the autofocus feature will work. The image shows up in the display window and the viewfinder goes black.
 
Last edited:

jcdeboever

Been spending a lot of time on here!
Joined
Sep 5, 2015
Messages
19,866
Reaction score
15,919
Location
Michigan
Can others edit my Photos
Photos OK to edit
Did you clean the electronic connection as described?

Sent from my XT1254 using Tapatalk
 
OP
M

mr.mike

TPF Noob!
Joined
May 7, 2013
Messages
133
Reaction score
12
Location
S.E.
Can others edit my Photos
Photos NOT OK to edit
Did you clean the electronic connection as described?

Sent from my XT1254 using Tapatalk

Cleaning the contacts was one of my first choices. I tried alcohol and Q-tip and even a pencil eraser. As mentioned, if placing the selector in the program mode, the camera will take a photo, but the autofocus feature is totally dead. The meter does show activity. If I activate the auto lock feature, the lens will autofocus. But again, if I place the selector in full auto, nothing happens at all.
 

AKUK

No longer a newbie, moving up!
Joined
Feb 1, 2015
Messages
344
Reaction score
266
Location
Kent, United Kingdom
Can others edit my Photos
Photos NOT OK to edit
Is there an option in the menu to reset to camera defaults? Seems odd that the AF will kick in under certain situations but not others. I'm not ruling out that there is a fault with the camera but, at the moment I'm wondering if a setting is maybe the problem?
 
OP
M

mr.mike

TPF Noob!
Joined
May 7, 2013
Messages
133
Reaction score
12
Location
S.E.
Can others edit my Photos
Photos NOT OK to edit
Is there an option in the menu to reset to camera defaults? Seems odd that the AF will kick in under certain situations but not others. I'm not ruling out that there is a fault with the camera but, at the moment I'm wondering if a setting is maybe the problem?

Very strange situation, most features seem to work, but not the way they were intended. Total auto feature does not work, except when in the auto locking position. This one has me totally puzzled.
 
OP
M

mr.mike

TPF Noob!
Joined
May 7, 2013
Messages
133
Reaction score
12
Location
S.E.
Can others edit my Photos
Photos NOT OK to edit
Is there an option in the menu to reset to camera defaults? Seems odd that the AF will kick in under certain situations but not others. I'm not ruling out that there is a fault with the camera but, at the moment I'm wondering if a setting is maybe the problem?
Hi,
An improper setting could certainly be at fault. That being said, I'm at a loss for correcting it if that is the case.
 

Most reactions

Top