Coolpix P300 SDHC card issue - HELP!

adgain

TPF Noob!
Joined
Feb 23, 2012
Messages
3
Reaction score
0
Location
London
Can others edit my Photos
Photos NOT OK to edit
Hi There,
I've just recently purchased the Nikon Coolpix P300 P&S camera. I've been loving the camera but was only able to use a very small memory card (256MB SD) until I bought something bigger.

I decided to clear the small 256MB SD card so removed the SD from the camera and put it in my computer's SD card reader. I cut and paste the photos onto my computer and when I tried putting the SD back into the camera it came up with the message:

"Memory card is write protected" on the screen.

After buying a brand new Sandisk 8GB SDHC (which is supported by the camera) I put it in the camera and the same message appeared. I made sure the lock switch on the SDHC card was in the "write" position but it comes up with the same message, whatever card is in the camera.

The in-built camera memory works fine and is recordable and formattable.
The SD and SDHC cards both do not work even after formatting however do work in other cameras and are readable by our computers so it must be the camera.

Can anyone help??
You're my only hope.

adgain
 

sleist

Been spending a lot of time on here!
Joined
Nov 8, 2009
Messages
3,831
Reaction score
2,272
Location
Boston
Can others edit my Photos
Photos NOT OK to edit
Have you tried re-formatting the card in the camera? This should be done after each transfer performed from a device other than the camera itself.
 
OP
A

adgain

TPF Noob!
Joined
Feb 23, 2012
Messages
3
Reaction score
0
Location
London
Can others edit my Photos
Photos NOT OK to edit
Unfortunately I have tried that too and without success.
I formatted both cards in the computer and they still get the "Memory card is write protected" message.
Plus when either of the SD/SDHC cards is inserted in the camera, the camera's format memory option is non-selectable.

:S
 

sleist

Been spending a lot of time on here!
Joined
Nov 8, 2009
Messages
3,831
Reaction score
2,272
Location
Boston
Can others edit my Photos
Photos NOT OK to edit
You need to format them "in the camera". Formatting them in the PC may be the cause of the problem.
There should be a menu option to format the card in the camera's menu somewhere.


** OOPS - just re-read your last post. I still think that formatting the card in the PC may have caused the problem. What filesystem did you use to format the card?
 
OP
A

adgain

TPF Noob!
Joined
Feb 23, 2012
Messages
3
Reaction score
0
Location
London
Can others edit my Photos
Photos NOT OK to edit
Actually, I'm not sure. I just clicked yes to format and breezed through quickly.

Am I correct in thinking I should be formatting to FAT32?
 

sleist

Been spending a lot of time on here!
Joined
Nov 8, 2009
Messages
3,831
Reaction score
2,272
Location
Boston
Can others edit my Photos
Photos NOT OK to edit
I really don't know for certain. Not even sure this is the cause.
I would not think that fat32 would cause you to not be able to format the card in the camera, but NTFS might.
Also, try creating a folder in the card (on the PC) and then right click on the folder and see if the folder was created as read only.
If so, uncheck the read-only flag on the folder and then try to format the card in the camera again.

Anything else I might suggest would be even more of a guess at this point. I might try to reproduce the error at home, but I don't have the same camera.

Another option might be to use nikon software like View NX2 and Transfer NX to access the card instead of using the card as an USB hard drive as you seem to be doing.
These progs are free for download off the Nikon USA site.

Current versions of Nikon software

HTH
 

Most reactions

New Topics

Top