Epson r1800 problem

Discussion in 'Photography Equipment & Products' started by D-50, Sep 17, 2007.

  1. D-50

    D-50 TPF Noob!

    Feb 15, 2006
    Likes Received:
    New England
    Can others edit my Photos:
    Photos NOT OK to edit
    Last night I did a system recovery and had to reinstall all my programs everything went fine until tI tried to print a 11x16 photo. My R1800 prints anywhere from a tenth to a third of the photo and then runs the rest of the age through blank and the monitor box appears and saya the mediais not loaded correctly. The setting on the printer setup are right for a3 paper but the printer does not recognize this. After it ejects the paper it will print a couple pages of numbers and letteres. Any idea what is going on here?
    I need a quick fix as I need to print out photos for a show next week.

    I have deleted the drivers and reinstalled them a couple times as well as unplugged the printer,what else can i do.

    Before I did the recovery my printer worked fine.


Share This Page