Problem with 580EX master in wireless

Discussion in 'Beyond the Basics' started by Tiberius47, Sep 12, 2008.

  1. Tiberius47

    Tiberius47 TPF Noob!

    Oct 4, 2007
    Likes Received:
    Can others edit my Photos:
    Photos NOT OK to edit
    I've got a problem with my 580EX mk I flash when I am using it as a master in wireless mode. I want to disable it so that only the 430EX mk II fires to light the subject. However, despite following the instructions in the manual (p36) and also the instructions on THIS website, I can't stop the 580 from firing.

    I've made sure that it isn't the prefire flashes that are used to communicate with the slave flash because I have done it in a darkened room with no slave flash and photographed a blank wall, and there is still light appearing. The only place it could come from is the master flash, despite it being set to off.

    The specific problem is this. I have the flash icon on the LCD display with the little light beams coming out of it. I press and hold the "zoom" button until "Off" and the ratio icon flash. I make sure that the on/off setting is at "Off" and I press the set button. According to the manual, the little lightning bolt icon below the flash icon should flash, but when I do it, it doesn't flash. And according to the above linked website, the little light beams should disappear from the LCD display, but on mine they remain.

    Am I missing something? Is my flash stuffed?


    I;ve changed the channel of the master 580 to channel 2, and that lets me get rid of the light beam icon from the LCD display, but it appears that the flash is still firing during the exposure. I've taken photos of the blank wall, and also the camera's own reflection, and they both show the flash firing during the exposure (although it is firing very dimly).

    Last edited: Sep 12, 2008

Share This Page