Help with Yongnuo YN622C II wireless triggers

Discussion in 'Lighting and Hardware' started by paul_jw, Feb 28, 2018.

  1. paul_jw

    paul_jw TPF Noob!

    Joined:
    Feb 28, 2018
    Messages:
    5
    Likes Received:
    0
    Can others edit my Photos:
    Photos OK to edit
    I bought a pair of YN622C triggers (used, online from B&H). While they seem to work (basically), they don't seem to work properly, and I'm wondering if that is because I'm doing something wrong. My camera is a Canon 80D. At the same time I bought an (also used) Yongnuo YN568EX II flash. The hotshoe of the flash was loose and wobbly, but this was easily corrected by taking off the bottom and tightening some screws.

    The flash works perfectly when directly on the camera hotshoe. It is reliable, and it exposes correctly.

    If I put one YN622C on the camera and attach my Yongnuo flash to the other one, I observe the following:

    - If the flash is on, it flashes as I connect it to the transmitter - it then generally does not fire remotely.
    - If I connect the flash to the trigger's hotshoe while the flash is off, and then turn it on, it does work, at least at first.
    - Sometimes the flash fires but the image is totally dark - I believe that the flash is not firing at the right time (too early vs. too late). Most of my testing has be done in manual mode with a shutter speed of 1/60. I have high speed sync turned off, and the flash is set to first curtain. (I have experienced the same thing with second curtain and high speed sync on - though it might have worked better with high-speed sync, which shouldn't make sense at 1/60?)
    - Sometimes the flash works properly once or twice. Even seeming to work in ETTL, though I have done much of my testing in manual. (Even at 1:1 I have several examples where if fires but the image is totally dark.)
    - After one or two successful fires, the flash stops responding to the YN622C - the transmitters seem to be speaking to eachother, but the flash just won't fire. If I restart the flash (generally by opening the battery door and then restarting it), it works, again for a few flashes. This does not appear to be related to recharging, because I can wait several minutes between exposures with no effect, and it recycles rapidly when on the camera hotshoe.
    - Even when the flash doesn't fire, the transmitters ARE communicating. If I change the flash settings on the camera, the new settings (zoom, ETTL vs manual, output) are successfully transmitted to the flash. So it doesn't seem to be a communication breakdown.

    The behaviour is even stranger if I connect my Canon 580EX II to the transmitter. But the behaviour is TOTALLY different.
    - Each time I trigger the flash, it fires twice with a significant delay. The first flash is always dim, and underexposes. I thought this was an ETTL problem, but the same thing happens in manual! Always two flashes, separated by about a second.
    - However, the flash ALWAYS fires, so clearly there is no problem with communication between the units.

    I have tried every conceivable setting... The problems persist. It would be easy to believe that the YN622Cs are defective in some way, but I can't help but think I'm setting something wrong... I have verified that group and channel are set correctly - both units have CH C1, group A. The transmitters are set to 622 mode.

    The test button will reliably fire the flash - both pressing it on the YN622C on the camera and pressing it on the one connected to the flash. However when the flash stops firing it also stops responding to the test button.

    The double firing with the Canon speedlight also occurs with the test button!

    Any suggestions would be most welcome. I don't think I will be able to return them as they were bought used and I did not have a chance to test them within the first week, so I think I missed my return window.

    Thanks,

    Paul


     
  2. paul_jw

    paul_jw TPF Noob!

    Joined:
    Feb 28, 2018
    Messages:
    5
    Likes Received:
    0
    Can others edit my Photos:
    Photos OK to edit
    Tiny little additional detail. With the Canon speedlight, the delay between the two flashes is very short if I use the test button on the transmitter connected to the camera - a fraction of a second, but definitely noticeable as two flashes. When I use the test button on the other transmitter, the delay is over a second.

    Sorry for the long post. Hope someone has advice.

    Paul
     
  3. Cody'sCaptures

    Cody'sCaptures No longer a newbie, moving up!

    Joined:
    Jan 31, 2017
    Messages:
    247
    Likes Received:
    101
    Location:
    Chicago
    Can others edit my Photos:
    Photos OK to edit
    I had odd problems with my triggers until I updated the firmware. I'll get an occasional no fire still but maybe worth a try

    (Updated)
    here's the site
     
    Last edited: Mar 1, 2018
  4. FotosbyMike

    FotosbyMike No longer a newbie, moving up!

    Joined:
    Feb 3, 2015
    Messages:
    279
    Likes Received:
    78
    Location:
    Charlotte, NC
    Can others edit my Photos:
    Photos NOT OK to edit
    Make sure your flash exposure bracketing, flash exposure compensation are set to 0. Not sure if it affect external flashes but make sure Red-Eye Reduction is off.
     
  5. paul_jw

    paul_jw TPF Noob!

    Joined:
    Feb 28, 2018
    Messages:
    5
    Likes Received:
    0
    Can others edit my Photos:
    Photos OK to edit
    Alas, still not working. Upgraded firmware - no change. Checked all those settings - all set correctly. I find it weird that both flashes work perfectly on camera, and neither works on the YN622c - but they both fail completely differently. One new thing I've noticed - with the Yungnuo flash on the YN622c the first image is usually dark on top (variable amount of the top is dark), the second image is usually OK and then the flash stops firing. (But still responds to setting changes.)

    I'm not sure if these are defective YN622c's or if there is a compatibility problem with my camera (80D). I'll try them on my old 60D... If they work there, then I guess it is just not compatible with my camera. If they still don't work, I wonder if it is worthwhile to try another pair of YN622c's... (But don't want to throw away even more money.)

    Paul
     
  6. FotosbyMike

    FotosbyMike No longer a newbie, moving up!

    Joined:
    Feb 3, 2015
    Messages:
    279
    Likes Received:
    78
    Location:
    Charlotte, NC
    Can others edit my Photos:
    Photos NOT OK to edit
    If you haven't done a factory reset on the triggers this is how you do it;
    YN622C - Factory Reset 1) Hold down the buttons [CH SET] plus [GP SET] at the same time. 2) The state indicators will blink for 3 times in red-green alternately then turn to keep lighting (red). 3) Release all the buttons then reset the factory set
    YN622C-TX - H o l d d o w n t h e [ M O D E ] a n d [SYNC/FN] buttons at the same time until the screen as shown, then loosen to restore factory settings
     
  7. Braineack

    Braineack Been spending a lot of time on here!

    Joined:
    Jun 17, 2013
    Messages:
    11,871
    Likes Received:
    4,741
    Location:
    NoVA
    Can others edit my Photos:
    Photos OK to edit
    I remember having a similar issue with my SB-700 -- the TTL would always pre-flash on the Nikon flash if trying to use TTL or Manual settings via the 622; so the flash itself had to be used in manual mode.
     
  8. paul_jw

    paul_jw TPF Noob!

    Joined:
    Feb 28, 2018
    Messages:
    5
    Likes Received:
    0
    Can others edit my Photos:
    Photos OK to edit
    The factory reset seems to have helped minimally. The YN586 still doesn't work. First exposure - only the bottom of the image has flash, second exposure seems to be ok, third exposure - flash no longer fires. This is basically the same issue. I'm at 1/60 so it shouldn't be a "high speed sync" issue. (Using normal 1st curtain.) With the Canon flash - I'm not longer getting the double fire, but the timing of the flash is still off. The images are either black or only exposed on the bottom. I keep trying to play with various settings - no effect. I went to 1/250 and turned on high-speed sync - same issue. tried slower shutters (1/40) - same issue. Not sure if this means flash firing too early or too late - I suspect too late... Tried to play with some of the more obscure camera settings including "flash sync speed in Av mode" - none of the three setting choices seem to work. But with one of them (1/250 to 1/60) the flash would only fire several seconds after the exposure.

    I have barely even tried TTL - my first step in troubleshooting was to go to manual. The TTL definitely produces the double fire...

    Gonna try my old camera and fresh batteries in everything. Then I think I'm gonna give up...

    Thanks, everyone, for the help.

    Paul
     
  9. paul_jw

    paul_jw TPF Noob!

    Joined:
    Feb 28, 2018
    Messages:
    5
    Likes Received:
    0
    Can others edit my Photos:
    Photos OK to edit
    Exact same issues with my Canon 60D. So its not the flashes, the cameras or presumably the settings. Therefore I conclude that the wireless receivers are simply defective. Oh well... I guess thats the downside to purchasing used equipment online. I might order another pair with the assumption that one of the two I currently own is probably OK and then I will have three...

    Paul
     
  10. FotosbyMike

    FotosbyMike No longer a newbie, moving up!

    Joined:
    Feb 3, 2015
    Messages:
    279
    Likes Received:
    78
    Location:
    Charlotte, NC
    Can others edit my Photos:
    Photos NOT OK to edit


    Yeah I think you have done all you can, it is a bummer to have them not working right. I have been using these triggers for 4-5 years with a YN586II and a Canon 430EXII with no issues. Maybe only one is bad and you lose out on both, pick up another one then troubleshoot. Good luck.
     

Share This Page