AE-1 and AE-1 Program film release button stuck


TPF Noob!
Mar 14, 2021
Reaction score
Can others edit my Photos
Photos NOT OK to edit
I have 2 Canon AE-1's, a regular AE-1 and an AE-1 Program. Both camera's have the black film release button on the bottom of the camera depressed in the down position and I can move the manual advance lever or fire the camera. I verified both camera's have good batteries.

The AE-1 (my Dad's old camera) will meter if the trigger is presses and the mechanism inside the works, but the black arm won't adavance anything. Attaching my Dad's old power winder to the camera did not help.

The AE-1 Program has a good battery in it, but I can't get the electronic meter to light up when pressing the trigger.

Both cameras are currently unloaded and I have fresh film to put in.
Did a bit more research and it looks like it's the electromagnet in the camera. I took the bottom plate off the Program and there is a silver lever that would not release. I manually released it and the film advance arm now works fine. The black button under the camera did pop back up. I can advance the film, but it still won't fire and allow the mechanism to move to the next frame, unless I move the lever. Did the same thing to the AE-1, same result, the film advance arm now moves, but the camera does not fire

Quick note, I actually used the AE-1 a few years ago and it worked perfectly
Last edited:
Well, the AE-1 is now fixed. Cleaned the contacts on the magnet, works like a charm now. The Program now lights up after I put the AE-1's battery into it, cleaned the contacts and it's still not working right. I'm going to get a couple of brand new batteries and see if that helps. The mechanism cycles perfectly on the Program, just need to make a few more adjustments

Most reactions

New Topics