Canon A1 no power


TPF Noob!
May 28, 2021
Reaction score
Hi all,

First post. I'm not a photographer but I spotted an A1 at a yard sale for 5 bucks and had to get it out of curiosity. Came with the 135mm and 50mm lenses which is cool. Everything is in great physical shape. Was in a case that still had the owner's manual and even the receipt where he bought it new back in '83! So it doesn't seem to have been dragged around and abused through the years.
The problem is that the camera has no power at all. I put in a brand new battery, and nothing. The battery compartment is perfectly clean.
I see no light meter in the viewfinder like on my AE-1, no little red battery indicator light on the top of the camera, and the shutter doesn't work. It's dead.
If I pop the bottom off the camera and manually release the shutter by popping loose the electromagnet, the shutter fires and the camera can be cocked again. But it never fires with the shutter button at all.
I tried grounding the electromagnet on the frame screw and it still didn't release. I tried cleaning the magnet contacts and nothing.
Just wondering if there's any other easy (as in, something a layman can accomplish) thing I can try before I give up. Any help or ideas are really appreciated!

- Cris
I was hoping for something more encouraging, but I fear you might be right. Maybe time to just jettison this baby.
Unfortunately, this is not uncommon with A-series Canons. Some work and some are dead. But, you still got a great deal on the lenses.
that is why one is supposed to test the electronic cameras made before 2000.

Most reactions