Canon Rebel XS and Canon 24-70mm Error

nickyb

TPF Noob!
Joined
Jun 18, 2013
Messages
1
Reaction score
0
Location
United States
Can others edit my Photos
Photos NOT OK to edit
I have a Canon Rebel XS which I got over three years ago. Recently I purchased a Canon 24-70mm lens from Amazon. At first, it worked great. But then (after the warranty expired) I began to get the Error 99 message. I cleaned the contact points and updated the firmware, but the error continued. Fortunately, it only comes up immediately after the camera has been turned on and I take the first picture. Then I take out the battery and the camera and lens work fine. It is a pain and I would prefer not to deal with it. My other lenses do not give this error and I tried the lens on two other Canon camera bodies belonging to a friend (5D II and 5D III) and the lens performs beautifully without the error. So it seems like there is some error between my camera body and this particular lens. Has anyone else experienced this? What should I do?
 

Overread

has a hat around here somewhere
Staff member
Supporting Member
Joined
May 1, 2008
Messages
25,372
Reaction score
4,943
Location
UK - England
Website
www.deviantart.com
Can others edit my Photos
Photos OK to edit
Cleaning the contact points on both the camera and the lens is the first port of call for most lens to camera errors. If you've cleaned the contacts and it seems also tested both units on other gear its sounding odd that they have a specific clash with each other; but it does suggest that one of the units does have a fault that is showing up under repeatable conditions.

The problem is Er99 is a catch all term for "something is wrong, I don't know what" from the camera. The only way to get an answer is to send the items into Canon to have a look at them. I would err on the site that the potential error is in the older camera body which has more chances for wear and tear damage through simple use; though the fact that both units operate as normal with other items suggests it could be something minor on both that is causing the clash.

I'd give the contacts another clean - phone up and talk to the service centre and do as you're doing in looking around the web to see if anyone's had a similar problem. Try asking around independent as well as Canon's own service centre; if you can't find a solution chances are you'll either have to live with the problem or send the units in.
 

gmazz

TPF Noob!
Joined
Mar 3, 2013
Messages
23
Reaction score
2
Location
Toronto
Can others edit my Photos
Photos OK to edit
Are you sure it's not the cf card? I had a similar problem and had to replace the card.
 

Most reactions

ClickASnap

New Topics

Top