flash problem


TPF Noob!
Apr 7, 2009
Reaction score
New Jersey
Can others edit my Photos
Photos OK to edit
I'm having a problem with one of my flashes, its a vivitar 285hv. I'm using a Cactus V4 setup for off-camera flash, and it isn't firing with it. The transmitter and reciever are both lighting up, I tried with another flash and everything worked fine. I also tried my 285hv right on my camera's shoe and that worked fine as well. Any help would be awesome.

Thanks everybody.
It sounds like it could be a connection problem between the flash foot and the hot shoe on the receiver. Make double sure that it's seated correctly.

You could also try connection the flash to the receiver via a cord. The receiver has a standard monoplug connection and the flash may or may not have a sync port. It may even be a special Vivitar port, which would require a special cord/plug.

You could also get a hotshoe adapter that has a standard monoplug, then all you would need is a simple patch cord to go from one to the other.

And of course, the cactus triggers are only $40...so sometimes, you get what you pay for.

Most reactions

New Topics