🌟 Exclusive 2024 Prime Day Deals! 🌟

Unlock unbeatable offers today. Shop here: https://amzn.to/3LqnCuJ 🎁

Problem with Minotola X700 Action Lever

rhs51206

TPF Noob!
Joined
Feb 20, 2012
Messages
2
Reaction score
0
Location
not st. louis, MO
Can others edit my Photos
Photos OK to edit
I recently purchased a 1984 Minotola X700 camera, used, and before purchasing, I was informed of a problem with the lever that makes it unable to push the film through the camera, thus I am not able to take pictures. Does anybody have any idea how to fix this or who might know? Info is much appreciated, as I am very new to the photography profession. Thank you very much and God Bless!
 
I fed the film into the teeth of the take up spool(gray gear at bottom with teeth), tightened the film like its supposed to be, closed the backing, turned the camera on, tried to use the film advance lever to start the roll of film, but was unable to do so. I tried advancing it by hand using the take up spool, but it still didn't work. I would really like to be able to take pictures with my new camera, so can someone please help me??
 

Most reactions

New Topics

Back
Top