Vivitar 285HV not firing

Discussion in 'Photography Equipment & Products' started by topstep, May 12, 2009.

  1. topstep

    topstep TPF Noob!

    May 12, 2009
    Likes Received:
    I used this flash with an old Minolta srt100 and always used a little power cord going to the body of the camera. Then I sold it. Today I got this from th guy who bought my Flash unit. Anybody have any ideas what's going on?

    I put in some AAs and it test fired beautifully. So I put it in my gear back for Thursday's shoot. Just before the shoot I set up all of my equipment and tried testing my flashes with my wireless triggers. Everything worked great except for your 285. It will no fire from a hot-shoe. The test button works but nothing else will fire it. I tried it on several different triggers as well as on each of my dSLRs (a D200 and a D40).

    More info

    1. I'm attempting to fire the flash from a hot-shoe, the way it was designed. The little chord is for cameras that have a "cold" shoe. I did try to fire the strobe with my D200 and the sync-chord but that did not work either.

    2. I have several 285hvs, both vintage and the new models made in china. Haven't had the issue with any other items.

    Any ideas out there?


Share This Page