Problem with SB-700--it WON'T turn off!


TPF Noob!
Apr 21, 2011
Reaction score
Can others edit my Photos
Photos OK to edit
I tried to use my SB-700 yesterday off camera to do some water droplet shots. I was going to trigger it with my new Cowboy radio slave. 3 things happened that were bothersome to me.

First, the radio slave did not trigger the flash but just a few times. Most of the time, the flash did not fire. It was set up correctly I believe since it did fire a time or two, but the other times? For the record, I switched to using the YN 560 flash which worked perfectly!

Second, I tried to adjust the power output and nothing worked on the back of the flash. I pushed the buttons and nada. It was as if the flash had frozen.

Third, when I tried to turn off the SB-700 and turn it back on, it would NOT turn off even when I put it on the "off" position. It finally turned off but it took several minutes of me monkeying with it.

Has anybody else experienced these problems?
I've got a completely different set up but with the same thing. If I use Yongnuo RF602 receivers with Sigma Super 530 flash guns they are prone to freezing up and the only thing that works is a 'battery pull'.

I guess some combinations of triggers and flashes just aren't meant to be.
I had the same issue (not turning off) with my sb-700 with impact powersync16. I turned off the Standby mode in my sb-700 and it fixed this issue. Hope this helps.
Last edited:
Hi, I was wondering if you ever found a solution to this problem over the past year. I have been experiencing it, exactly the same way, repeatedly with my two SB-700s. I am at my wit's end. I use Pocket Wizard TT5s to trigger them, and half the time they don't fire. The TT5s are fine, they work perfectly with my YN-502. The problem is only with the SB-700s. I need to take off the batteries and start over each time. It will be ok for a few shots, then it won't work. Sometimes they do shut off, but not always.
The "standby" mode is off. The batteries are new and fresh.
Mine doesn't shut off sometime too. Dunno why.
Usually, it's in slave mode. I just pop the battery door open for a second, then close it back up.

Most reactions

New Topics