🌟 Exclusive 2024 Prime Day Deals! 🌟

Unlock unbeatable offers today. Shop here: https://amzn.to/3LqnCuJ 🎁

Issue with Olympus OM30: stuck in Aperture Priority, cannot change shutter speed when in manual?

howdoesonecla

TPF Noob!
Joined
Jun 30, 2021
Messages
4
Reaction score
0
Can others edit my Photos
Photos NOT OK to edit
So i bought this untested Olympus OM30 thinking it would be ok since the seller knew nothing about cameras judging by everything else they were selling. When it arrived I put in new batteries and tried using it however, it would only work in "Auto" mode, even if i switched it to Bulb or Manual it would still choose its own shutter speed, does anyone have idea of how I could fix this?
 
are you changing the shutter speed on the side of the lens mount?
 
The manual suggests it will still display the shutter speed it wants to shoot at (even while in Manual Mode), but setting it to Manual will override this.

Have you actually tested it? You should easily be able to hear the difference between the speeds.


1625069261882.png



here you can see the meter says it wants to shoot at 1/250sec. The user then meters the face to get 1/80sec, sets the shutter to 1/80, recomposes back to the original framing and you can see the meter still shows 1/250sec.
 
Hi, yes I've just tried that and it still doesn't do anything, the camera picks it's own settings, even while in bulb, I've also come across another problem which is the battery door doesn't close tight enough to give the camera power at all times unless you push it while holding it.
 

Most reactions

Back
Top