Canon Eos-1n film camera problem

Dawid

TPF Noob!
Joined
Jun 21, 2021
Messages
2
Reaction score
1
Can others edit my Photos
Photos NOT OK to edit
Hi there! I'm using a film camera canon eos-1n with a grip (power driver booster e1) since last year and I was so happy to find such a great camera! But since last week I'm having an issue with it. After turning the camera on, the shutter realases by itself. After that I can't take anymore photos. And when I look into the viewfinder the in-focus indicator flashes like crazy. I already changed the batteries in the grip and tried to turn on the camera without lenses attached. Can it be a problem with shutter button or the power system?
 

Mike Drone

No longer a newbie, moving up!
Joined
Jun 13, 2020
Messages
847
Reaction score
434
Location
Yuma, AZ
Can others edit my Photos
Photos NOT OK to edit
One shot AF? Something like this, "Two types of autofocus are available: One-shot AF and AI Servo AF. Further, the shutter will not release if the in-focus indicator is blinking. It blinks because due to out of range on focusing capability or even when combines with the fact that exposure is not properly metered for a good exposure. Try refocusing the subject on an alternate subject with higher contrast at approximately the same distance, or use manual focusing" from an online owner's manual here.

In that case, I am going to have to leave it to someone that has more wisdom on the subject. Sorry that it is not working out for you.
 
Last edited:
OP
D

Dawid

TPF Noob!
Joined
Jun 21, 2021
Messages
2
Reaction score
1
Can others edit my Photos
Photos NOT OK to edit
Thanks Mike! I tried to change the AF mode as you recommended but it still wont let me control the shutter realase. It only take the picture when I turn on the camera and that's it, no more pictures. Unless I turn it off and on again. It's just so frustrating... When I focus manually I can see the red flashing square in the viewfinder (so the object is sharp) but the shutter button doesn't work at all.
 

Most reactions

Top